RDelpopolo

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • in reply to: Compiling a network card driver? #50128
    RDelpopolo
    Member

    If you still need this driver, i’ve managed to compile it and i can send it to you.

    in reply to: Multiwan without netbalancing and port forwarding. #50655
    RDelpopolo
    Member

    It don’t work if netbalancig or failover isn’t active

    RDelpopolo
    Member

    But i want the windows webserver to be reacheable on port 80 and both the webserver and the windows desktop download the windows updates without authentication allowing any other think only once authenticated.

    in reply to: Netbios resolution problem #50743
    RDelpopolo
    Member

    resolve netbios name from different subnets
    It seem that the only way is to use a wins server.
    Does anyone know if there is any other way?

    in reply to: internet is unreachable from ZeroShell host [SOLVED] #50751
    RDelpopolo
    Member

    Probably your ap has the dhcp enabled.

    Does your ap and zs had the same ip?

    in reply to: internet is unreachable from ZeroShell host [SOLVED] #50749
    RDelpopolo
    Member

    What was the problem?

    in reply to: internet is unreachable from ZeroShell host [SOLVED] #50746
    RDelpopolo
    Member

    can you ping it with the integrated utilities?
    Maybe the interaces are inverted?

    in reply to: internet is unreachable from ZeroShell host [SOLVED] #50744
    RDelpopolo
    Member

    Have you set the default gateway on zeroshell?

    in reply to: Multiwan without netbalancing and port forwarding. #50653
    RDelpopolo
    Member

    Rebooted zeroshell, enabled the netbalancer and setted as failover, and now it works.

    I’m going to see how to patch zeroshell to make the portforwarding work on multiwan withouth enabling the netbalancer with atheling patch.

    Thank you for your kind support πŸ˜€

    in reply to: Multiwan without netbalancing and port forwarding. #50651
    RDelpopolo
    Member

    I can’t use only one dsl.
    I need that the webserver result reacheable with both the dsl.

    ETH00 is my dsl1
    ETH01 is my dsl2
    ETH02 is my internal lan

    DSL1 is a bridged dsl modm with a public ip. From here the webserver is reacheable
    DSL2 is a routed dsl modem with a public ip. It have as internal ip 192.168.0.1. I’m already forwarding the port from this routed modem to the zeroshell. From here the webserver is unreacheable.

    /edit
    If i go on Conection tracking i get someting like:
    tcp 6 104 SYN_SENT src=8(omiss2)5 dst=8(omiss)0 sport=54189 dport=80 packets=5 bytes=300 [UNREPLIED] src=8(omiss)0 dst=8(omiss2)5 sport=80 dport=54189 packets=0 bytes=0 mark=0 use=1

    192.168.1.8 = my private ip.
    added (omiss) and (omiss2) to cover the public ips.
    (omiss) = public ip of DSL2 (the webserver unreacheable)
    (omiss2) = public ip of DSL1

    ad here the result of iptables -t mangle -vn -L

    Chain PREROUTING (policy ACCEPT 200K packets, 86M bytes)
    pkts bytes target prot opt in out source destination
    465 30862 MARK all — ETH01 * 0.0.0.0/0 0.0.0.0/0 state NEW MARK set 0x64
    449 30094 MARK all — ETH01 * 0.0.0.0/0 0.0.0.0/0 state NEW MARK set 0x64

    Chain INPUT (policy ACCEPT 92315 packets, 47M bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 107K packets, 39M bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 92377 packets, 48M bytes)
    pkts bytes target prot opt in out source destination

    Chain POSTROUTING (policy ACCEPT 200K packets, 87M bytes)
    pkts bytes target prot opt in out source destination
    8594 3569K QoS all — * * 0.0.0.0/0 0.0.0.0/0

    Chain NB_CT_POST (0 references)
    pkts bytes target prot opt in out source destination
    0 0 MARK all — * * 0.0.0.0/0 0.0.0.0/0 realm 0x66 MARK set 0x66
    0 0 MARK all — * * 0.0.0.0/0 0.0.0.0/0 realm 0x65 MARK set 0x65
    0 0 CONNMARK all — * * 0.0.0.0/0 0.0.0.0/0 CONNMARK save

    Chain NB_CT_PRE (0 references)
    pkts bytes target prot opt in out source destination
    0 0 MARK all — ETH01 * 0.0.0.0/0 192.168.0.2 MARK set 0x66
    0 0 MARK all — ETH00 * 0.0.0.0/0 8(omiss2)5 MARK set 0x65

    Chain NB_FO_PRE (0 references)
    pkts bytes target prot opt in out source destination

    Chain NB_STAT (0 references)
    pkts bytes target prot opt in out source destination
    0 0 all — * * 0.0.0.0/0 0.0.0.0/0 MARK match 0x66
    0 0 all — * * 0.0.0.0/0 0.0.0.0/0 MARK match 0x65

    Chain NetBalancer (0 references)
    pkts bytes target prot opt in out source destination

    Chain OpenVPN (0 references)
    pkts bytes target prot opt in out source destination

    Chain QoS (1 references)
    pkts bytes target prot opt in out source destination

    RDelpopolo
    Member

    Can you explain me better the thinks to do?
    I’m a newbie and can’t make it to work πŸ™

    Can you give me the commands that you run to marlk correctly the packets?

    in reply to: Multiple ISP, servers on LAN #49168
    RDelpopolo
    Member

    Can you explain easily how to solve that problem?

    in reply to: Date of a new release #50034
    RDelpopolo
    Member

    Does this patch solve the multiwan virtual server problem?

    in reply to: Qos and NB – Atheling’s patch #50302
    RDelpopolo
    Member

    I’ve the same problem.
    Can you attach it here in the forum?

    Thank you πŸ™‚

    /edit
    Solved!
    I had to ignore white spaces.
    So the command to be run is:
    patch -lp0 < Zeroshell.patch

    in reply to: HTTP Proxy Transparent Proxy with Web Antivirus setup #49586
    RDelpopolo
    Member

    Today i’ve tryed the same configuration (2 bridged + 1 for administration), and I had the same problem.
    After some attempts, i’ve figured out the problem and managed it to work.
    The proxy, once intercepted the http connection, need to connect itseft to internet, so the bridged connection need an ip that could connect to internet!

    Probably i’m wrong but, it seem that HAVP in transparent proxy mode doesn’t manage the http connection as expected, opening a new connection to internet to retrive the data requested by the client to analize the incoming stream with clamav, instead to analize the incoming and outgoing stream to drop the “bad” one on the fly.

Viewing 15 posts - 1 through 15 (of 15 total)