lennart

Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • in reply to: Hard Drive Install hangs at boot #47363
    lennart
    Member

    I have almost got LILO working in ZeroShell. My approach is in this thread:http://www.zeroshell.net/eng/forum/viewtopic.php?t=1477

    Since i didn’t gwt it to work 100% I have submitted a featurerequest for LILO support here : http://www.zeroshell.net/eng/forum/viewtopic.php?p=4412#4412

    Hope this was helpfull.

    in reply to: Change CF Image size #47888
    lennart
    Member

    If i were to shrink the image i would do the following:

    1. Mount the partition that has the most extra space under some folder
    2. Tar the contents into a tarbal, (remebering the -p option)
    3. Unmount the partition
    4. fdisk the image and remove the partition
    5. create a new partition with a more suitable size
    6. create a new filesytem on the new partition
    7. mount the new partiton under some folder
    8. uncompress the tar backup (remembering the -p option)

    🙂

    in reply to: Alternate Bootloader #48357
    lennart
    Member

    After the initial steps above I have gone through alot of trial and error and googling to arrive at the following tips:

    1. To have the kernel find the correct root, simply look at the errormessages the kernel give out before “kernel panic VFS bla bla”. It will list the alternatives. Simply put the most likely alternative given your configuration as the root= paramete in your lilo.conf.

    look at my lilo.conf in the previous post and you will see my root parameter on the line starting with “append”.

    2. The ramdisk size must be more than 131megabytes for the boot to work. I figured out the size requirement by by looking at the grub.conf and by testing with the following command:


    root@katana:/media/CDROM# du -sh
    131M .

    The errormessage if the size is too small is:

    Loading root filesystem into RAM device... Fail

    3. The kernel claims that it cant find the init executable, and asking for an init= parameter. I am a bit puzzled because the grub config does not seem to mention a special init parameter, and that is usually left to the default of /bin/init or /sbin/init or something like that. This could indicated some problem with the mounting of hte ISO root filesystem.

    This is how far I have come. I will investigate further.

    Any help or suggestions are appreciated!

Viewing 3 posts - 1 through 3 (of 3 total)