zerone

Forum Replies Created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • in reply to: How to stopping named sevice #49539

    zerone
    Member

    @misterplow wrote:

    It’s an ugly hack, but what you have to do is kill named, and then before it gets launched again restart openvpn (to grab udp/53).

    Does this Post Boot script do what you need?

    /bin/killall named;/etc/init.d/openvpn restart

    Setup your OpenVPN server listening on ucp53 (it will fail to start the first time you save it). After this is created, execute the Post Boot script as above or else reboot your box.

    Does that work?

    thanks for your quick respon…

    i’ll try it later…and i’ll give the result

    love u 🙄

    in reply to: Virtual Server #48324

    zerone
    Member

    JC, ppalias Thanks for your quick response

    @ppalias wrote:

    Port forwarding works in Routed mode, not in Bridge mode.

    in my case i’ve said “Bridging Mode” is not really bridging..

    i mean that i set my modem ADSL on eth0 with bridge mode
    so i can dial to my PPPOE service with ZS…

    without adding NIC or Vlan now i can forward port (ZS) to LAN Server..(web server, etc) the problem is Captive Portal.

    I have to give a Free Authorized Clients (CaptivePortal) my Webserver on my LAN…

    thanks guys…

    in reply to: Virtual Server #48320

    zerone
    Member

    @thegmin wrote:

    Back again, was on a trip 🙂
    Ok so I did the port redirection, but something just doesnt fit, I redirected all public port 80 access to a http server with 10.10.10.3 IP on port 80. OK so far so good, but when i try any domain, I end up starring at zeroshell’s login page. Cuz it also uses port 80. So do i have to change the port of the zeroshell web interface or something else?

    sorry JC, i want to ask you some questions.
    is it true, if i had only 1 Ethernet card in Zeroshell (ETH0) and my PPP0 is from modem ADSL on ETH0 (bridging mode) then forwarding port (virtual server) function didn’t work?

    cause i have tried that and never got work! 😡

    – port forwarding only works if destination local remote ip is zeroshell’s private ip

    thanks
    sorry for my bad english

    pls reply ASAP (i’m so stressed out to solve these problems)

    in reply to: Install Zeroshell in SCSI hard drive. #46954

    zerone
    Member

    i’ve been using zeroshell almost 7 month,

    and yeah,.. it could be installed on SCSi harddisk,

    i’ve tried eleazar tips and its working for me

    in reply to: Download Manager Resume Issue #48105

    zerone
    Member

    i’ve found the problem

    when i didn’t capture eth00 (LAN) or vpn interface with HAVP resuming was working, but if i did this log for proxy LAN access to internet was not working too…

    dear fulvio pls fix this…


    zerone
    Member

    @bender02 wrote:

    editing the files in zeroshell needs to be done via ssh, so
    – run ‘ssh admin@’
    – it asks for a passwd, so go ahead with it
    – then press ‘s’ (for ‘s’hell), after a password it should drop you into a shell
    – edit /etc/passwd; the only editor I found installed by default on zeroshell is vi/vim, so ‘vim /etc/passwd’ (read something about editing in vim beforehand, if you haven’t done it before)
    – copy the first line (begins with root:x: ), so that you have it twice and edit one of them. you need to change the first thing before ‘:’ to the actual username you want to use, and then you might want to change the default directory (with root it’s “/root”) to something else (like “/home/”) [then you need to create this directory, run ‘mkdir /home/’ in shell]; save the file, exit the editor
    – edit /etc/ssh/sshd_config, so ‘vim /etc/ssh/sshd_config’. Find the line that with “AllowUsers admin” and change it to “AllowUsers admin “. Save the file, exit the editor. It is important that you don’t mess up this file, since if it’s faulty then sshd won’t restart properly and you won’t be able to ssh to your machine.
    – restart the ssh daemon. This is best done from gui, so finish the ssh session (‘exit’ on the shell prompt exits to the menu, and then ‘ctrl+c’ exits the session). Go to your zeroshell gui, click on ‘SSH’, uncheck “Enabled”, click “Save”, check “Enabled”, click “Save”. This restarts the ssh daemon.
    – now if you’ve added the user properly to kerberos’ database (in gui, click on “Users”, etc…), you should be able to ‘ssh @’ and after entering the password, you should be in (a shell prompt).
    – if it doesn’t work, check your ssh logs (in gui, click “Logs”, then select “sshd”)

    – WARNING: these changes are not persistent, so after rebooting the zeroshell, you need to do them again (I haven’t looked into this, so I don’t know now how to make them persistent).

    – you don’t need any extra things for sftp, it’s set up on by default. So if your ssh login as a user works, just use any sftp client to connect to zeroshell. You can use ‘sftp @’, or ‘scp @:’

    thanks for your reply but i’ve found out to do this myself (after searching in google)

    1. i make user via gui… (exp: zerone)
    2. i run to shell with this command:
    useradd zerone -p (anyword)
    3. vi /etc/ssh/sshd_config
    AllowUsers admin zerone
    4. restart ssh service via web
    5. viola now i can login with my user…

    Now i want to search the way how to put this configuration to startup script…
    Maybe mr Fulvio can help me?

    Thanks all
    Thanks mr fulvio for your good work of Zeroshell

    in reply to: Logging in to zeroshell’s ssh as a user (not admin) #48045

    zerone
    Member

    @bender02 wrote:

    I found out that in order to login to zeroshell’s ssh as any user different from admin (ie as users added to kerberos’ database via the web interface), I need to do 2 more things that I didn’t figure out how to do via the web interface, I had to do them via ssh:
    1) add that user to /etc/passwd
    2) add that user to AllowUsers in /etc/ssh/sshd_config
    otherwise ssh complains that it’s an invalid user and doesn’t authenticate.

    The positive outcome of this is that now I can use sftp and scp to copy files to/from zeroshell (which wouldn’t work with the ‘admin’ user, since its ‘login shell’ script sends some text automatically on each login, which throws off all the s{cp,ftp} clients).

    1st question: is there an easier way to enable sftp-server subsystem on zeroshell to actually function (btw, it runs by default, but it’s unusable).

    2nd question (I guess to fulvio) is: is this so by design, or would I have a chance requesting a feature to add the possiblity to do these 2 changes via the web gui interface? Thanks. [btw, fulvio, thanks for this otherwise excellenty running system! I really love it.]

    i need your help.. pls give me step by step how you do 2 things. cause i’m not good in unix system command…

    i’ve created new user but i cant login ssh with it..

    and i need guide to do sftp too..

    thanks

Viewing 7 posts - 1 through 7 (of 7 total)