Shiv

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • in reply to: Block unknown MAC address to access internet #53493

    Shiv
    Member

    @gopalakrishnank wrote:

    Dear Shiv,
    you told as ARP Commands written.
    I dont know how to write that. please guide for this.my requirement is I want to block unknown new ip cannot connect with My LAN Network.

    command > arp -s IP_address MAC_address

    in reply to: Block unknown MAC address to access internet #53491

    Shiv
    Member

    @gopalakrishnank wrote:

    Dear Shiv,
    Please guide me for this. i newbie to zeroshell. how can i achieve this.if u have any reference provide me.

    Thanks in advance

    I cleared that as above, can’t understand what you want more. For ref. please visit the link : https://www.zeroshell.org/forum/viewtopic.php?p=6005&sid=03ca932f62d033f324dd56408a24aa02

    in reply to: Block unknown MAC address to access internet #53489

    Shiv
    Member

    @gopalakrishnank wrote:

    Dear Shiv,
    Can you post your solution here. it is really helpful for me. please help me with your solution

    I blocked IPs which are not in use for now. Created an executable file for ARP commands and then set a post boot script = System>Setup>Startup/Cron , after that reboot the ZS.

    in reply to: Block unknown MAC address to access internet #53487

    Shiv
    Member

    @shiv wrote:

    @shiv wrote:

    @shiv wrote:

    Hi,
    I am using ZS 2.0 RC3. I want to fix an IP address for a specific MAC address only so no other device can use that IP either the device (for which IP address is fixed) is powered ON or OFF. My aim is a new machine with unknown mac address can’t access Internet.

    Please suggest how to do this.

    Done it successfully with ARP command. But if I want to unbind it what command will be used. Will -d command work for that?

    Pardon,,,, after a restart of ZS binding was not in effect it was not working. Bounded IPs are working with other devices also. Can someone help on this? What I missed?

    Finally it’s done. I set a post boot script for the commands and it worked.

    Thank you ZS Team 😀 😀

    in reply to: Block unknown MAC address to access internet #53486

    Shiv
    Member

    @redfive wrote:

    Hi Shiv, did you try by declaring, in firewall, forward chain, both source ip and source mac ?
    Regards

    Did you mean like in the image here? https://www.dropbox.com/s/bqwfld9vgyvf947/Screenshot-5.png?dl=0

    in reply to: Block unknown MAC address to access internet #53485

    Shiv
    Member

    @shiv wrote:

    @shiv wrote:

    Hi,
    I am using ZS 2.0 RC3. I want to fix an IP address for a specific MAC address only so no other device can use that IP either the device (for which IP address is fixed) is powered ON or OFF. My aim is a new machine with unknown mac address can’t access Internet.

    Please suggest how to do this.

    Done it successfully with ARP command. But if I want to unbind it what command will be used. Will -d command work for that?

    Pardon,,,, after a restart of ZS binding was not in effect it was not working. Bounded IPs are working with other devices also. Can someone help on this? What I missed?

    in reply to: Block unknown MAC address to access internet #53483

    Shiv
    Member

    @shiv wrote:

    Hi,
    I am using ZS 2.0 RC3. I want to fix an IP address for a specific MAC address only so no other device can use that IP either the device (for which IP address is fixed) is powered ON or OFF. My aim is a new machine with unknown mac address can’t access Internet.

    Please suggest how to do this.

    Done it successfully with ARP command. But if I want to unbind it what command will be used. Will -d command work for that?

    in reply to: Can’t access a particular site #53088

    Shiv
    Member

    @drmca wrote:

    Not sure why setting one of your uplinks to a static IP prevents you from pinging an address on the Internet.

    I have 2 uplinks and both use static IPs assigned by the provider and everything works fine with or without firewall.

    Are you doing all these diagnostics in ZS console or from a machine on your LAN? I would run diags on ZS directly using ssh first.

    I am accessing ZS console from a machine in LAN (web access). And I diagnosed all these on some machines in LAN which have Linux MAC and Windows OS. They are showing same results, the issue is with Static IP no firewall issue.

    in reply to: Can’t access a particular site #53086

    Shiv
    Member

    @drmca wrote:

    @shiv wrote:

    #1. Yes, I configured this connection directly (not on ZS) and tried the link is accessible from same connection. In ZS>DNS>OPTIONS> 208.67.222.222 AND 208.67.220.220 ARE SET. Is that right one for DNS??
    On Linux I tried traceroute and the below two lines are the result-
    1 192.168.0.75 (192.168.0.75) 0.181 ms 0.112 ms 0.106 ms
    2 192.168.0.75 (192.168.0.75) 2621.616 ms !H 2621.590 ms !H 2621.560 ms !H

    On windows the tracert shows the result –
    1 <1 ms <1 ms <1 ms 192.168.0.75
    2 192.168.0.75 reports: Destination host unreachable.

    #2. When I ping this site without using www from ZS the result is -> From 192.168.0.75 icmp_seq=6 Destination Host Unreachable. And once I tried ping with http://www.site name and the result is ->
    64 bytes from hit-nxdomain.opendns.com (67.215.65.132): icmp_seq=72 ttl=51 time=378 ms

    So you want to use OpenDNS, looks like your configuration for ZS DNS is correct.

    Is the address you are trying to reach 192.168.0.75? This address belongs to a local block of addresses, it’s not routable and can only be used on the LAN. I am not sure why you want to access that IP address, as it seems that in reality you want to use hit-nxdomain.opendns.com

    This is what I can see:

    D:>nslookup hit-nxdomain.opendns.com
    Server: ****************
    Address: 10.1.3.3

    Non-authoritative answer:
    Name: hit-nxdomain.opendns.com
    Address: 67.215.65.132

    67.215.65.132 is the external IP that you should use if you need to access host hit-nxdomain.opendns.com by IP address.
    Try to ping it and it most likely is going to work.

    A new thing I have observed. We have three interfaces and one of them has static IP so I added static IP to the relative ETH. This site is not accessible after adding the static IP and when I remove the IP, it is. I checked with balancing rules also but this issue persists. So suggest for this one now.

    in reply to: Can’t access a particular site #53085

    Shiv
    Member

    @drmca wrote:

    @shiv wrote:

    #1. Yes, I configured this connection directly (not on ZS) and tried the link is accessible from same connection. In ZS>DNS>OPTIONS> 208.67.222.222 AND 208.67.220.220 ARE SET. Is that right one for DNS??
    On Linux I tried traceroute and the below two lines are the result-
    1 192.168.0.75 (192.168.0.75) 0.181 ms 0.112 ms 0.106 ms
    2 192.168.0.75 (192.168.0.75) 2621.616 ms !H 2621.590 ms !H 2621.560 ms !H

    On windows the tracert shows the result –
    1 <1 ms <1 ms <1 ms 192.168.0.75
    2 192.168.0.75 reports: Destination host unreachable.

    #2. When I ping this site without using www from ZS the result is -> From 192.168.0.75 icmp_seq=6 Destination Host Unreachable. And once I tried ping with http://www.site name and the result is ->
    64 bytes from hit-nxdomain.opendns.com (67.215.65.132): icmp_seq=72 ttl=51 time=378 ms

    So you want to use OpenDNS, looks like your configuration for ZS DNS is correct.

    Is the address you are trying to reach 192.168.0.75? This address belongs to a local block of addresses, it’s not routable and can only be used on the LAN. I am not sure why you want to access that IP address, as it seems that in reality you want to use hit-nxdomain.opendns.com

    This is what I can see:

    D:>nslookup hit-nxdomain.opendns.com
    Server: ****************
    Address: 10.1.3.3

    Non-authoritative answer:
    Name: hit-nxdomain.opendns.com
    Address: 67.215.65.132

    67.215.65.132 is the external IP that you should use if you need to access host hit-nxdomain.opendns.com by IP address.
    Try to ping it and it most likely is going to work.

    I reinstalled the ZS and checked without adding any rule to firewall and found it’s working. But I am going to observe step by step where the issue is.

    in reply to: Can’t access a particular site #53084

    Shiv
    Member

    @drmca wrote:

    @shiv wrote:

    #1. Yes, I configured this connection directly (not on ZS) and tried the link is accessible from same connection. In ZS>DNS>OPTIONS> 208.67.222.222 AND 208.67.220.220 ARE SET. Is that right one for DNS??
    On Linux I tried traceroute and the below two lines are the result-
    1 192.168.0.75 (192.168.0.75) 0.181 ms 0.112 ms 0.106 ms
    2 192.168.0.75 (192.168.0.75) 2621.616 ms !H 2621.590 ms !H 2621.560 ms !H

    On windows the tracert shows the result –
    1 <1 ms <1 ms <1 ms 192.168.0.75
    2 192.168.0.75 reports: Destination host unreachable.

    #2. When I ping this site without using www from ZS the result is -> From 192.168.0.75 icmp_seq=6 Destination Host Unreachable. And once I tried ping with http://www.site name and the result is ->
    64 bytes from hit-nxdomain.opendns.com (67.215.65.132): icmp_seq=72 ttl=51 time=378 ms

    So you want to use OpenDNS, looks like your configuration for ZS DNS is correct.

    Is the address you are trying to reach 192.168.0.75? This address belongs to a local block of addresses, it’s not routable and can only be used on the LAN. I am not sure why you want to access that IP address, as it seems that in reality you want to use hit-nxdomain.opendns.com

    his is what I can see:

    D:>nslookup hit-nxdomain.opendns.com
    Server: ****************
    Address: 10.1.3.3

    Non-authoritative answer:
    Name: hit-nxdomain.opendns.com
    Address: 67.215.65.132

    67.215.65.132 is the external IP that you should use if you need to access host hit-nxdomain.opendns.com by IP address.
    Try to ping it and it most likely is going to work.

    I am not trying to reach 192.168.0.75 i am trying for 67.215.65.132 but it is not reachable from browser. and shared you the ping results for same as above.

    in reply to: Can’t access a particular site #53082

    Shiv
    Member

    @drmca wrote:

    You would have to perform some diagnostics to troubleshoot this.

    1. Can you resolve that site’s name from behind ZS (by the way, are you using ZS as a DNS server)?

    on Windows try nslookup or tracert
    on Linux try nslookup or traceroute

    2. Can you ping the site by name and IP address from behind ZS?

    3. Can you telnet into port 80 of the site, once in telnet type ? and you should see something like


    HTTP/1.1 400 Bad Request
    Content-Type: text/html; charset=us-ascii

    #1. Yes, I configured this connection directly (not on ZS) and tried the link is accessible from same connection. In ZS>DNS>OPTIONS> 208.67.222.222 AND 208.67.220.220 ARE SET. Is that right one for DNS??
    On Linux I tried traceroute and the below two lines are the result-
    1 192.168.0.75 (192.168.0.75) 0.181 ms 0.112 ms 0.106 ms
    2 192.168.0.75 (192.168.0.75) 2621.616 ms !H 2621.590 ms !H 2621.560 ms !H

    On windows the tracert shows the result –
    1 <1 ms <1 ms <1 ms 192.168.0.75
    2 192.168.0.75 reports: Destination host unreachable.

    #2. When I ping this site without using www from ZS the result is -> From 192.168.0.75 icmp_seq=6 Destination Host Unreachable. And once I tried ping with http://www.site name and the result is ->
    64 bytes from hit-nxdomain.opendns.com (67.215.65.132): icmp_seq=72 ttl=51 time=378 ms

    in reply to: Can’t access a particular site #53080

    Shiv
    Member

    @shiv wrote:

    Hi, I am unable to access a particular site through my Zeroshell network. While it is accessible from out of ZS with the same ISP. Please help someone regarding this.

    I disabled the firewall and checked but still it’s not working. I added an IP to firewall with privileges to access all the site but this one also not working. How to fix the issue now??

    in reply to: How to access Video Cam from out of Lan #52992

    Shiv
    Member

    @redfive wrote:

    The static ip is on ETH03 and not on ppp2 ? Have you tried shutting down all wan interfaces, except ETH03 and ppp2 and see if all works properly ? How is the firewall set up ?

    Nice…….!! it worked finally. Thanks a lot for your help.

    in reply to: Block Torrent on Zeroshell #52979

    Shiv
    Member

    @shiv wrote:

    Hi, I want to block torrent on Zeroshell. Could any buddy help me pls ??

    I blocked IPs in firewall which utorrent and bittorrent are using. Blocked tcp and udp ports from 6881-6999. Enabled layer7 filter in firewall for bittorrent but still unable to block download from torrent.

Viewing 15 posts - 1 through 15 (of 22 total)