ZS – default GW routing is not initialized @ boot/power up

Home Page Forums Network Management Networking ZS – default GW routing is not initialized @ boot/power up

This topic contains 1 reply, has 0 voices, and was last updated by  knura 8 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #42960

    knura
    Member

    I have dd’d the ALIX image of 1.0b14 on a 2GB CF and I am running it on a ALIX board (3 LAN) model.

    I have been able to create my own profile and configure the NICs to specific IP numbers of my network, change the CA to my domain etc. In order to route non-local traffic to the Internet, I have also setup up a “DEFAULT GATEWAY” via the Network>Router panel.

    However, each time I power up or reboot the system – everything comes up fine except that the default route is *not* setup automatically. Thus, there is no traffic flow to the Internet.

    The “DEFAULT GATEWAY” setting can be seen under “Network>Router” Static Routes but it shows “STATE” as down.

    I have to manually initialize the “Default Route/GW”, through the WebIf
    “Network>Router”

    1. Select the “DEFAULT GATEWAY” item
    2. Click on “Change” button.
    3. Click OK on the “Change” dialog box (pop up window)

    After above operation, default route is initialized and non-local traffic is routed to the Internet.

    The issue is that this has to be done each time the router box is powered up.

    Looking at the /etc/init.d/network script, it sources file /etc/sysconfig/network that contain empty strings for:

    GATEWAY=
    GATEWAY_IF=

    Am I missing something in the setup of the “DEFAULT GATEWAY”?
    Is there any setting to ensure that “Default Route” is up at boot up?

    TIA

    Arun Khan

    #51708

    aemarx
    Member

    im not sure if this help you. I set my default gateway at

    SYSTEM > Setup > Network > Gateway(button) .

    #51709

    knura
    Member

    @aemarx wrote:

    im not sure if this help you. I set my default gateway at

    SYSTEM > Setup > Network > Gateway(button) .

    Thanks. Your method does work.

    However, I was expecting that a definition of a “static route” entry under
    NETWORK > Router > Default GW also to be brought “up” at boot time.

    Another method that works for me:
    In the definition of a new “profile”, enter an IP number in the “GW” field. It must be on the same subnet of the interface. Later it can changed to route through any other interface.

    — Arun Khan

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.