ZS 3.3.2 Issue with e1000e Intel Ethernet driver

Home Page Forums Network Management ZeroShell ZS 3.3.2 Issue with e1000e Intel Ethernet driver

This topic contains 1 reply, has 0 voices, and was last updated by  cdpearce 4 years, 3 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #44253

    cdpearce
    Participant

    I recently upgraded from ZS 3.2.1 to ZS 3.3.2. I immediately was having big problems with the ethernet port built into the motherboard of the ZS box. The chip is Intel 82579V. It is controlled by the e1000e device driver. I have two other ethernet ports on an expansion card that uses Intel 82574L chips that were unaffected.

    When I check the information about the device driver in ZS 3.3.2 using “ethtool -i ETH00” I get this:

    driver: e1000e
    version: 2.3.2-k
    firmware-version: 0.13-4
    bus-info: 0000:00:19.0

    When I roll back to ZS 3.2.1 the same command shows:
    driver: e1000e
    version: 3.1.0.2-NAPI
    firmware-version: 0.13-4
    bus-info: 0000:00:19.0

    So, presuming that the e1000e release numbering is relatively sane, it would appear to have been regressed in the newest ZeroShell.

    Some sample from the kernel log for ZS 3.3.2:
    13:41:17 [136758.887942] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:19 [136760.885481] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:21 [136762.884863] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:23 [136764.884227] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:25 [136766.883630] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:25 [136766.892630] e1000e 0000:00:19.0 ETH00: Reset adapter unexpectedly
    13:41:29 [136770.790339] e1000e: ETH00 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
    13:41:33 [136774.881157] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:35 [136776.880535] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:37 [136778.879913] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:39 [136780.879282] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:39 [136780.888289] e1000e 0000:00:19.0 ETH00: Reset adapter unexpectedly
    13:41:43 [136784.795996] e1000e: ETH00 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
    13:41:45 [136786.879267] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:47 [136788.876827] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:49 [136790.876194] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:51 [136792.875575] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:53 [136794.874952] e1000e 0000:00:19.0 ETH00: Detected Hardware Unit Hang:
    13:41:53 [136794.884174] e1000e 0000:00:19.0 ETH00: Reset adapter unexpectedly
    13:41:57 [136798.791658] e1000e: ETH00 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

    etc.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.