ZeroShell on old Advantech PCM-5823 board

Home Page Forums Network Management Embedded Devices ZeroShell on old Advantech PCM-5823 board

This topic contains 6 replies, has 0 voices, and was last updated by  Paulox 9 years, 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #42040

    Paulox
    Member

    Hi,

    I’ve been trying all night long to setup ZeroShell on a small Geode board and didn’t succeed.

    I can’t get no signal from serial (even from CD boot) nor on NICs.

    The PCM-5823 is a board based on a Geode 300MHz (Fanless) and 128MB RAM. The only socket I have is a Compact Flash one declared as the Secondary Master (I know this could be an issue but I have no solution).

    Is it possible to modify the image on order to disable the Serial redirection? This way, I should be able to use the VGA interface to understand what’s happening.

    Please help me, after deep and long researches, ZeroShell is definitively the distribution I want on my old box.

    Thanks in advance for your help.

    Regards,

    #49114

    ppalias
    Member

    I have a Nova Board with the same CPU, Geode 300MHz Fanless, with both vga and serial output. It also has one IDE with master-slave, one adapter for 2,5″ ATA HDD and a cfdisk adapter, so I suppose we are running on the same hardware more or less.
    The vga is working by default, I never had an issue on that. Serial is enabled by the time grub is loaded to redirect output to serial.

    #49115

    Paulox
    Member

    Hi,

    Thanks for replying. From what you said, it seems effectively that we have the same kind of hardware.

    The VGA output is enabled but as soon as the serial output is activated I can’t get any signal on the serial (I suppose) and the VGA output it disabled.

    I was wondering if there was any chance to get another tty with the VGA enabled (stop me if I’m wrong but I suppose that the respawn to the serial output is activated for each tty).

    Maybe something is going wrong in the installation process.

    Even if I boot with the CD-ROM attached, the output is redirected to serial so I can’t even test the HDD installation process.

    Thanks in advance for your help.

    PS: which version of ZS are you running? Which is your BIOS version (I checked and I’m almost sure that my board is exactly the same taht the WAFER-5823 from Nova)?

    #49116

    ppalias
    Member

    I tried the Beta11 on that board. I am at work right now so I cannot answer about the BIOS version. There should be a way to prevent serial output, but I was not able to locate it in “/boot/grub/*”
    In case you cannot find it, try to connect through serial on the box.

    #49117

    Paulox
    Member

    Thanks, I tested Beta.12 so I’ll try with the previous version.

    As far as I remember, the serial ouput is enabled in the inittab file (which I don’t have access to).

    The option in the GRUB bootloader just allow you to have GRUB in the serial output so as soon as you boot, the inittab should be launched.

    I’ll tell you as soon as I’m at home.

    #49118

    ppalias
    Member

    You can tweak the innitab file. But I don’t think this is your problem as it has 2 outputs, one to the serial and another to the tty1.

    #49119

    Paulox
    Member

    After different testings, it appears that you were right, in the inittab file, both tty(1 and S0) are used.

    So my problem looks more like a Kernel panic (I get a screen fuzzing just after the line Checking if you processor honors,etc…).

    I tested the ALIX image but no more success (Error 13 of GRUB).

    I don’t know what to do next and I feel a bit desperated :cry:. I don’t want to give up but I have no more clues to move forward.

    I’d appreciate any advice.

    #49120

    ppalias
    Member

    On which ide channel is the disk connected to?
    Usually this problem is fixed by editing in /boot/grub/grub.conf the entry

    root (hd0,0)

    when the disk is not the primary.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.