Zeroshell install to HD (a year later)

Home Page Forums Network Management ZeroShell Zeroshell install to HD (a year later)

This topic contains 2 replies, has 0 voices, and was last updated by  squishydale 8 years ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41085

    squishydale
    Member

    First of all, thanks so much to fulvio for working out this fantastic guide to installing on a hard disk! Also to christiancolombini for the documentation.

    http://digilander.libero.it/smasherdevourer/schede/linux/Zeroshell%20su%20HD-EN.pdf

    I know there have been multiple threads on this topic, with multiple issues. I know this because i read them all trying to solve my problems. So forgive me for starting a new thread on this, but I saw a few other users experiencing the same problems that I was.

    Here’s my scenario: I’m installing Zeroshell on a Pentium II-450 MHz computer with 128 MB of pc133 RAM and a 6.4 GB hard drive. I found that 64 MB of memory will hang just after starting the web server (httpd), so if you are only making it that far booting from the CD, that’s probably your issue.

    Here was my issue
    :
    After following fulvio’s guide, I would reboot the computer and get an error that there was no bootable media found. This is a quick fix. When you gunzip the zeroshell image, it creates all of the right partitions for you on your hard drive, but at least for me, it didn’t make the first one bootable. So, boot back up from the CD, go to a shell by hitting , then:

    note: I use /dev/hda but be sure you use whatever path corresponds to your hd
    root@zeroshell root> fdisk /dev/hda
    > a
    > 1

    > w

    This toggles the bootable flag on the first partition. After rebooting, I no longer got the error, now I got “GRUB ERROR 2”. This was the one that took me a while to figure out. Ultimately, the problem had to do with the mode that my hard drive was being accessed. To fix this, I had to go manually set the mode in the BIOS.

    In my bios, when looking at the drives section, I have these options:
    TYPE – SIZE – CYLS – HEAD – PRECOMP – LANDZ – SECTOR – MODE

    I had the types for all drives set to AUTO and also for the modes on all drives. This is fine for funning windows 95 on your computer, but apparently it doesn’t work when running a zeroshell compact flash image. I had to change the type for my hard drive to USER and the mode to LBA. Once I did that, and rebooted, everything booted up just fine.

    Anyway, once again I want to thank everyone who has a hand in ZS, it is an awesome project.

    #46638

    imported_fulvio
    Participant

    Thanks a lot for all your comments. They will be useful for other users want to install zeroshell on the hard disk.

    Regards
    Fulvio

    #46639

    davidvella
    Member

    Hi folks,

    I’m new to the board and to Zeroshell. I just wanted to add that I just got an image installed onto a 1GB hard drive no problem first shot. Using Windows XP I downloaded the file “ZeroShell-1.0.beta10-CompactFlash-IDE-USB-SATA-1GB.img.gz” and expanded it with WinRAR (or whatever). Then I attached my HD via a USB-IDE adapter. In Windows Disk Management I found the disk as Disk #2 and I right-clicked to activate it. Then in WinImage (free at winimage.com) I picked the menu item “Disk” | “restore virtual hard disk image on physical drive”, clicked “include non removable hard disks” and selected “Disk 2”. A browse dialogue opens up and I selected “Files of type” *.* and then selected the .img file I had expanded. It took about 3 minutes for the bar to reach 100% then I reconnected the HD IDE cable in the Zeroshell box and up she booted.

    Now to configure and use the sucker!

    Regards,

    d.v.

    #46640

    ngwasuma
    Member
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.