Zeroshell for Raspberry Pi and Orange Pi

Home Page Forums Network Management ZeroShell Zeroshell for Raspberry Pi and Orange Pi

This topic contains 20 replies, has 13 voices, and was last updated by  Drazen Krnjeta 1 year ago.

Viewing 6 posts - 16 through 21 (of 21 total)
  • Author
    Posts
  • #54451

    i82blikeu
    Participant

    hi Fulvio,
    thanks for your job on this project.
    I’m exited to give “ZeroShell-3.8.1A-OPIPCPLUS.img.gz”a try but sadly it doesn’t boot on my PC+.
    It always got stucked at “loading kernel” during bootstrap

    Buone Feste


    g.

    #63825

    Aliaksei Zhukau
    Participant

    Hi, friends.

    I have got Zeroshell 3.8.2A on OPi-Zero up and running. Everything is perfect, fast and convenient, except one thing – I can’t find wifi interface. Supported Hardware page reads “Wifi module supported in Access Point and Client mode” for Orange Pi Zero. But only ETH00 is available at “Networks” page.

    Could you please clarify, is it possible to have wifi interface on Orange Pi Zero or not?

    #63830

    Xenek Stoehr
    Participant

    Hi, am excited to have an alternative to openwrt.

    In particular, while you don’t support Odroid, I have ARM qemu KVM running on my Odroid XU4, and I hope to run your RPi version on the odroid, mostly because it supports gigabit Ethernet & USB3, with more ram, EMMC, 8 CPUs and also – I can put a large SSD for long term persistent, reliable storage of the DB. EMMC is great for OS, but better is always SSD, and with USB3, SSD is a valid option on XU4.

    This is my wish, but first I need it 100% on the core hardware, a Raspberry Pi 3B. Only after it’s good on there for a month will I try move it across.

    I’ve some problems, mostly of the ‘information’ sort. I’m a tech so can give any detail you need, but not a Linux genius so cmds to extract data & rough paths help. Happy to break this out into multiple posts if needed.

    -PPPOE doesn’t work (pad errors? Maybe blacklisted by my ISP? Never connects.)
    -only one of 4 usb-ethernet adaptors work, no info (even rough) on how to install driver (if I can find Linux Arm one)
    -no procedure to permanently swap eth00 and eth01 so PPPOE can connect (assuming ISP MAC blacklist exists)
    -If I remove eg. eth01 (rtl usb-eth) then unplug, then replug, it doesn’t reappear, even after a reboot (and no procedure to redetect it exists, as far as I can tell)
    -No tips on how to change more advanced PPPOE details (eg path to config file, details on which module is used)

    Note I’m not overly concerned about having a user-space PPPOE module, but it’ll become an issue if it’s overloading the CPU. Given I want to run it in KVM, I might be able to get you good feedback on usage if you need a tester for beta releases.

    Best,
    xenek

    #63843

    Xenek Stoehr
    Participant

    Hi, have more info on the ppp0 errors (PPPoE Dialler for VDSL2+ in Australia on IInet)

    Before connecting RTL USB LAN

    20:48:45
    pppd 2.4.7 started by root, uid 0
    20:48:45
    Using interface ppp0
    20:48:45
    Connect: ppp0 <–> /dev/pts/0
    20:49:16
    LCP: timeout sending Config-Requests
    20:49:16
    Connection terminated.
    20:49:16
    Modem hangup
    20:49:20
    Exit.

    After connecting LAN

    20:50:46
    pppd 2.4.7 started by root, uid 0
    20:50:46
    Using interface ppp0
    20:50:46
    Connect: ppp0 <–> /dev/pts/0

    Then same as usual

    20:51:17
    LCP: timeout sending Config-Requests
    20:51:17
    Connection terminated.
    20:51:17
    Modem hangup
    20:51:22
    Exit.

    PPPoE connection (xDSL and cable modem)
    Interface PPP0

    Modem connected to ETH01

    Checking ‘show info’ PPP0

    ppp0: <POINTOPOINT,MULTICAST,NOARP> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 3
    link/ppp
    RX: bytes packets errors dropped overrun mcast
    0 0 0 0 0 0
    TX: bytes packets errors dropped carrier collsns
    0 0 0 0 0 0

    Checking ETH01

    ETH01: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 00:e0:4c:68:02:11 brd ff:ff:ff:ff:ff:ff
    RX: bytes packets errors dropped overrun mcast
    12296 114 0 0 0 0
    TX: bytes packets errors dropped carrier collsns
    3166 75 0 0 0 0

    same thing, over & over again.

    20:57:25
    pppd 2.4.7 started by root, uid 0
    20:57:25
    Using interface ppp0
    20:57:25
    Connect: ppp0 <–> /dev/pts/0
    20:57:56
    LCP: timeout sending Config-Requests
    20:57:56
    Connection terminated.
    20:57:56
    Modem hangup
    20:58:01
    Exit.

    -tried again a few days later to allow for temp blacklist (no change)

    -added static IP in new subnet to ETH01 (no change)
    192.168.1.5 255.255.255.0

    -reboot while everything attached. (no change)

    -changed MTU from shell (no change)

    Any tips on new things to try?
    Thanks x

    #64009

    Oscar Parzon
    Participant

    Hola !.
    it will work?
    Odroid XU4
    * Samsung Exynos5422 Cortex™-A15 2Ghz and Cortex™-A7 Octa core CPUs
    * Mali-T628 MP6(OpenGL ES 3.1/2.0/1.1 and OpenCL 1.2 Full profile)
    * 2Gbyte LPDDR3 RAM PoP stacked
    * eMMC5.0 HS400 Flash Storage
    * 2 x USB 3.0 Host, 1 x USB 2.0 Host
    * Gigabit Ethernet
    * Linux Kernel 4.14 LTS

    #64237

    Drazen Krnjeta
    Participant

    Hi,

    When can we expect 3.9.0 for Orange Pi R1 ? Thanks in advance…

    Draza.

Viewing 6 posts - 16 through 21 (of 21 total)

You must be logged in to reply to this topic.