Zeroshell CaptivePortal not working

Home Page Forums Network Management ZeroShell Zeroshell CaptivePortal not working

This topic contains 0 replies, has 0 voices, and was last updated by  ovidiu 5 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #43621

    ovidiu
    Member

    Hi,

    I’m trying to use this great product for creating a Captive Portal in a small public place. Because i don’t have a public IP addres, i decided to use ZS in BridgeMode. My setup is like this:

    ISP—> Gateway (192.168.1.100) < ---> (ETH00) ZeroShell Bridge (ETH01) < ---> WiFi or LAN

    Unfortunately this setup is not working when CaptivePortal is Enabled (tried to activate on Bridge & LAN). DHCP also is not working, not getting any ip addres nor with CaptivePortal de-activated.Everything seems to be fine with CaptivePortal OFF and manual IP address. When i try a ping toward GW, i’m getting a Destination Port Unreachable form interface ETH00 wich is the interface of ZS toward GW.

    Thank you

    #52716

    ik.omoruyi
    Member

    There are solutions out there for this.
    Here is my solution:

    Login as admin

    goto Router –> NAT

    On the NAT popup page, move ETH00 and ETH01 from Available Interfaces to NAT Enabled Interfaces, then save it and close it.

    goto DHCP and click on the New button and create a network on the New DHCP Subnet definition window that pops up(select ETH01).
    After creating the network, with the network now showing in the subnet, In the Dynamic IP Configuration section, select the IP range you want, click save in the main DHCP window, Active on: NONE should change to Active on: ETH01.

    goto Captive Portal, on the Interface dropdown menu, select ETH01, enable the Active on: checkbox and save. After saving the status should become Active on: ETH01.

    Now anybody connected to ETH01 port should get a dhcp address from what you specified earlier on and when trying to do anything will prompted with a login screen. Hopefully, you’ve set up users already.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.