Zeroshell Captive Portal Not Secure Messages

Home Page Forums Network Management ZeroShell Zeroshell Captive Portal Not Secure Messages

This topic contains 0 replies, has 0 voices, and was last updated by  saraara 1 year, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #44818

    saraara
    Member

    Hello All,

    I have configured zeroshell and everything is working per my need. However there is one thing I am having lots of troubles.

    The problem is captive portal and security warning. All of my client has default page set-up as https://www.google.com

    When they get captive portal authentication page (to enter username and password to access Internet) then on all browser they get warning messages, such as:
    “Your connection is not private”
    “There is a problem with this website’s security certificate”
    “Not secure”

    If they ignore above messages then there is no problem and they can access Internet just fine. However they hesitate at first and some client just do not use internet at all due to above warning messages.

    I checked “Do not use HTTPS (Encryption)” per suggestions but no help.

    Attached is my captive portal – authentication page.

    How do I solve this issue? Any help or tutorial will be greatly appreciated.

    #54474

    saraara
    Member

    After doing some reading I am answering my own question.

    There is no way to get rid off the cert error. It will be like hijacking ssl cert.

    The problem I have is a industry wide problem of captive portal mechanism. It was good until it lasted…or until more and more companies started using https.

    the best bet is to allow 80 only for captive portal redirection. That’s the best can be done to avoid cert warning.

    Hope this helps someone like me under frustration.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.