ZeroShell Captive Portal + Linksys WRT54GL

Home Page Forums Network Management Networking ZeroShell Captive Portal + Linksys WRT54GL

This topic contains 1 reply, has 0 voices, and was last updated by  rachidi 10 years, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #40832

    rachidi
    Member

    Hello
    Excuse for my English. Thank for your good job.
    I have problems with my Zeroshell Configuration.

    My architecture is the next :

    Users Connected by Wifi (10.0.0.0/16)
    |
    |
    Linksys WRT54GL (With Freifunk and OLSR – Wifi 10.0.1.1/16 )
    Wan 172.0.0.2/24 (OLSR)
    |
    |
    172.0.0.1/24
    ZeroShell (With 2 Network Cards)
    192.168.1.2
    | (my lan)
    |
    192.168.1.1
    Gateway
    |
    |
    (INTERNET)

    I activated the portal captive, it works well.

    My problem is that the captive portal retrieves the IP and MAC address of the Linksys router, not the IP address and MAC address of the user connected to the linksys.

    As a result, when a user is logged on , the captive portal allows access to the network without authentication for other wifi users, because the first user has transmitted the IP and mac address of linksys router.

    How can I do for captive portal retrieves the IP address or MAC address of each machine connected by WiFi linksys router?

    Thanks.

    #46025

    ceciox
    Member

    Sorry for my bad english!

    I have the same problem, on linksys there is a NAT betwen wan and lan(with olsr routing), so zeroshell can view only the IP of WAN! I think there is no solution on zeroshell, perhaps in olsr configuration… I wrote to freifunk community to know if there is a solution to this problem but I had no answer. I don’t know if there is a solution in freifunk configuration becouse I think Nat is the only way to make possible communication betwen olsr(that is all routed) and Zeroshell. The OLSR protocol need connect the gateway on wan to generate a route to gateway, with the NAT problem!
    Other way can be make zs a olsr node! But I am not able to make this…

    Someone can suggest something?

    #46026

    Phil6
    Member

    Hello Rachidi,

    The behaviour of your linksys is normal. It’s because you use it like a router an not an access point.

    The router will make NAT between your “wifi-side”(10.0.0.0/16) of the linksys and the “Wan-side” (172.0.0.0/24).

    If you use it like an access-point, the linksys will ‘bridge’ user on the wifi side to the lan-side. So your ZeroShell will see the MAC&IP of your wifi user and not the MAC&IP of the wan-side of your Linksys.

    The solution is to connect your linksys to your ZeroShell with an lan-port and not the wan-port of the linksys

    example:

    Users Connected by Wifi (172.0.0.5->254)
    |
    |
    Linksys WRT54GL (ip 172.0.0.2 and disable the DHCP server !!)
    Lan-port
    |
    |
    172.0.0.1/24
    ZeroShell (With 2 Network Cards + Enable the DHCP server for the subnet 172.0.0.1/24 from 172.0.0.5 to 172.0.0.254)

    I hope it will help you (an other) 😉

    Regards,
    Phil.
    (also sorry for his English )

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.