Zeroshell behind a router

Home Page Forums Network Management ZeroShell Zeroshell behind a router

This topic contains 3 replies, has 0 voices, and was last updated by  seba 9 years, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #41850

    seba
    Member

    Hi there,

    I tried to set up the following scenario: ZeroShell box behind a router with one interface which directly gets a dynamic ip from a router which has the ip 192.168.1.1 (I know this does not really make a lot of sense but it is just a testing environment).
    The outgoing interface is ETH0 and gets the ip 192.168.1.15 from the previously mentioned router over DHCP.
    The other interface ETH1 should be the one where I plug my network to. So I enabled the NAT on the ETH0 interface. Now setting up the default gateway does not really work since I know that it is 192.168.1.1 but the GUI wouldn’t accept it. Has anyone an idea how I could possibly set this up correctly?

    thx
    s)

    #48598

    ppalias
    Member

    It should already have the default gateway aquired by DHCP. If you want to set it by yourself disable DHCP and you will be able to configure it.

    #48599

    gbigras
    Member

    The “router” section of the GUI might not show a static entry for the default gateway and clicking on the default gw button will most likely return an empty field (mine is like that).

    However if your dhcp is configured correctly on the router the ZS GUI should display a default gateway entry in the routing table.

    #48600

    seba
    Member

    Turns out, the router box itself can access the internet but routing does not work. Maybe I missed something, but I already set up the NAT as described in the tutorial.

    #48601

    gbigras
    Member

    A bit more info would be useful. 😀

    Is your router a linux box ? Cisco ?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.