Zeroshel and Apcupsd mod

Home Page Forums Network Management ZeroShell Zeroshel and Apcupsd mod

This topic contains 9 replies, has 0 voices, and was last updated by  r1vver 1 year, 6 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #42797

    r1vver
    Participant

    Few days ago I get not new but still good working APC Smart-UPS. And of cource first my thought was to get Apcupsd to control my UPS and to correctly shut down my Zeroshell box in case of power failures.

    Websearch provided me link http://0sh-mods.net/ (zeroshell mods) with apcupsd 3.14.8 mod for Zeroshell (I think that it’s the right Zeroshell).

    And my questions are:
    Did anyone try this Apcupsd mod with Zeroshell?
    Will it work with ZeroShell-1.0.beta12 (hdd installed)?
    How to configure Apcupsd conf after installation of mod (web interface or shell and do i need nano for it or something similar)?
    Do i need to put anything in preboot?

    By myself i’ll be able to try this mod only on this weekend, so any information will be helpfull.

    #51462

    I’m having same issue as well, anyone know about this?

    #51463

    reaperz
    Member

    Tried to get apcupsd to work with recent 3.0.0 zeroshell. UPS is detected via USB. apcupsd says can’t find UPS, seems USBHIDEV kernel module is still missing!

    #51464

    reaperz
    Member

    Since I did not get it working, i did buy ASUS RT-N16 router and added Shibby Tomato AIO firmware to that. It has apcupsd integrated. With that 50 EUR solution you can get to monitor APC UPS via USB. Plus you get nice 802.11n wifi (theor max 300mbit/s on dual channels).

    #51465

    vedrokompot
    Member

    reaperz,

    Do you tried to install apcupsd in Zeroshell 3.2.1?
    Maybe kernel 3.4.90 or 3.14.21 has USBHIDEV module?
    I have same problem, i need use APC with Zeroshell, but i`m beginner with Linux, and i dont know should i try to install apcupsd in 3.2.1 release or not, because it would difficult for me.
    Thanks in advance!

    P.S.: Can apcupsd running on ASUS RT-N16 correctly shutdown Zeroshell box when power down? apcupsd daemon doing it via net?

    #51466

    reaperz
    Member

    I was not interested in shutting down machine, only wanted to create UPS load, temp and voltage graphs.

    But now with new 3.14.21-ZS-PAE I got apcupsd working!

    cd /Database/

    downloaded 0sh-mods-apcupsd-3.14.8-v1.1.tar.bz2

    tar xvfj 0sh-mods-apcupsd-3.14.8-v1.1.tar.bz2
    cd 0sh-mods-apcupsd-3.14.8-v1.1
    ./install.sh
    cd /Database/

    run the daemon:

    /Database/opt/1.0/beta12/packages/sbin/apcupsd -f /Database/opt/x.x/packages/etc/apcupsd/apcupsd.conf

    and run the command to get status:

    /Database/opt/1.0/beta12/packages/sbin/apcaccess status

    #51467

    vedrokompot
    Member

    Thanks for the detailed reply! But I can’t find 0sh-mods-apcupsd-3.14.8-v1.1.tar.bz2 anywhere. I searched on this forum, after this i googled – unsuccessfully. Site http://0sh-mods.net/ is down, i try several times on different days, but its still down. Or, my provider blocked this site. Can you post here link to 0sh-mods-apcupsd-3.14.8-v1.1.tar.bz2 mod ?

    thanks again!!!

    #51468

    reaperz
    Member

    Well, seems that domain 0sh-mods.net has expired. Guess the owner did not want to pay for that any more.

    I uploaded 2 files that i downloaded from that site long ago (iftop is unrelated to apcupsd but also nice utility):

    99.ee/0sh-mods-apcupsd-3.14.8-v1.1.tar.bz2
    99.ee/0sh-mods-iftop-0.17-v1.0.tar.bz2

    I did not add http:// in front of the links, don’t want bots crawling on my site.

    #51469

    reaperz
    Member

    Has anyone got apcupsd working with Zeroshell 3.8.0?

    Last time I used apcupsd with ZS was I think at version 3.5.0.

    But now adding more routers I wanted to monitor one UPS. And since there are no other Linux/Unix machines available, I tried to use ZS router for it.

    But now no. UPS is found via USB but starting apcupsd does not work:

    [1087287.170485] usb 1-5.1: new low-speed USB device number 4 using xhci_hcd
    [1087287.711729] usb 1-5.1: New USB device found, idVendor=0463, idProduct=ffff
    [1087287.711736] usb 1-5.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [1087287.711741] usb 1-5.1: Product: Eaton 5P
    [1087287.711744] usb 1-5.1: Manufacturer: EATON
    [1087287.711747] usb 1-5.1: SerialNumber: G114G45055
    [1087291.464143] usbcore: registered new interface driver usbhid
    [1087291.464147] usbhid: USB HID core driver
    [1087291.481215] hid-generic 0003:0463:FFFF.0001: collection stack overflow
    [1087291.481232] hid-generic 0003:0463:FFFF.0001: item 0 1 0 10 parsing failed
    [1087291.481277] hid-generic: probe of 0003:0463:FFFF.0001 failed with error -22
    [1087351.713344] usb 1-5.1: USB disconnect, device number 4
    [1087352.703995] usb 1-5.1: new low-speed USB device number 5 using xhci_hcd
    [1087353.249147] usb 1-5.1: New USB device found, idVendor=0463, idProduct=ffff
    [1087353.249170] usb 1-5.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [1087353.249174] usb 1-5.1: Product: Eaton 5P
    [1087353.249178] usb 1-5.1: Manufacturer: EATON
    [1087353.249181] usb 1-5.1: SerialNumber: G114G45055
    [1087356.984619] hid-generic 0003:0463:FFFF.0002: collection stack overflow
    [1087356.984633] hid-generic 0003:0463:FFFF.0002: item 0 1 0 10 parsing failed
    [1087356.984676] hid-generic: probe of 0003:0463:FFFF.0002 failed with error -22
    [1087417.250187] usb 1-5.1: USB disconnect, device number 5

    Seems I get stack overflow and USB disconnect every time I start apcupsd.

    I don’t know if problem is with ZS or apcupsd.

    #51470

    http://www.apc.com/shop/us/en/products/UPS-Network-Management-Card-2/P-AP9630

    18:51:03 apcupsd 3.14.8 (16 January 2010) unknown startup succeeded
    18:51:03 NIS server startup succeeded
    19:02:34 UPS Self Test switch to battery.
    19:02:34 Cannot exec /etc/apcupsd/apccontrol startselftest: No such file or directory
    19:02:54 UPS Self Test completed: Battery OK
    19:02:54 Cannot exec /etc/apcupsd/apccontrol endselftest: No such file or directory

    #51471

    reaperz
    Member

    Any news about apcupsd and Zeroshell 3.8.1?


    ~> /Database/opt/1.0/beta12/packages/sbin/apcupsd -f /Database/opt/x.x/packages/etc/apcupsd/apcupsd.conf
    ~> /Database/opt/1.0/beta12/packages/sbin/apcaccess status
    Error contacting apcupsd @ localhost:3551: Connection refused
    [1547508.458799] usb 1-5.1: USB disconnect, device number 102
    [1547509.423557] usb 1-5.1: new low-speed USB device number 103 using xhci_hcd
    [1547509.955687] usb 1-5.1: New USB device found, idVendor=0463, idProduct=ffff
    [1547509.955696] usb 1-5.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [1547509.955702] usb 1-5.1: Product: Eaton 5P
    [1547509.955707] usb 1-5.1: Manufacturer: EATON
    [1547509.955712] usb 1-5.1: SerialNumber: G114G45055
    [1547509.955907] usb 1-5.1: ep 0x81 - rounding interval to 128 microframes, ep desc says 160 microframes
    [1547513.690256] hid-generic 0003:0463:FFFF.5C6B: collection stack overflow
    [1547513.690273] hid-generic 0003:0463:FFFF.5C6B: item 0 1 0 10 parsing failed
    [1547513.690339] hid-generic: probe of 0003:0463:FFFF.5C6B failed with error -22
Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.