WPA multiple clients single credentials problem.

Home Page Forums Network Management ZeroShell WPA multiple clients single credentials problem.

This topic contains 8 replies, has 0 voices, and was last updated by  rochajoel 11 years, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #40811

    rochajoel
    Member

    This should be realy simple…

    WPA let’s me authenticate 2 or more machines with the same login credentials, how can i change that so that the first/last machine that entered the credentials is the one that manages to access the network(the other is simply droped)

    #45978

    imported_fulvio
    Participant

    You should use the attribute

    Simultaneous-Use = 1

    in the configuration file /etc/raddb/users of the FreeRadius.
    At the moment the web interface of Zeroshell does not manage
    this Radius attribute.

    Regards
    Fulvio

    #45979

    ncat987
    Member

    Is there a list of commands that are applicable to the zeroshell OS as well a description of their functionality. I am anxious to try out different commands and “tweak” the system and make it a bit more robust and increase usability.

    #45980

    rochajoel
    Member

    I tryed this:

    echo “DEFAULT Auth-Type = System, Simultaneous-Use = 1” > temp.txt
    echo ” Fall-Through = 1″ > temp2.txt
    cat temp.txt temp2.txt > /etc/raddb/users

    But after a while i could not make connections from any machine… 😳

    #45981

    imported_fulvio
    Participant

    You should try with

    Auth-Type = LDAP

    because the FreeRadius of Zeroshell uses the OpenLDAP backend DB with the same passwords used by Kerberos.

    Regards
    Fulvio

    #45982

    rochajoel
    Member

    i tried with LDAP, the radius service doesn’t even started…
    i tried with Local, and it still let’s me authenticate from 2 computers at the same time…



    I guess i’m just learning to work with this, i configured the radius in the startup script, and guess what, that was of no use… because the server will start with no configuration at all, and only afterwards the configuration is written to the users file…. What a waste of time ❗

    Any way, i already tried to do this:
    DEFAULT Simultaneous-Use = 1
    Fall-Through = 1

    which i saw in here: http://www.radius.cistron.nl/README.simul

    but even this way doesn’t work… i’m guessing maybe it’s because the accounting server is not ready yet…

    And also… what i said before that the System Auth-Type doesn’t work after a while is not true, it works, my intel 2100 is the one that is crappy and some times it does not authenticate, i don’t know why, but is some crappy piece of hardware that i’m 😡 since the beginning

    #45983

    rochajoel
    Member

    I guess it’s true… The accounting must be activated… it says right here in the freeRADIUS FAQ: http://wiki.freeradius.org/index.php/FAQ#Simultaneous-Use_doesn.27t_work

    Fulvio, do you think it’s possible to fix this manually in the shell prompt? does Zero Shell has the the right version of pearl? last time i checked it didn’t had the gcc and i was unable to compile transproxy (which i would if i knew how to cross compile…)

    #45984

    imported_fulvio
    Participant

    I never tried to enable the accounting in FreeRadius and hence I do not know how hard is to activate. You can download the gcc used to compile Zeroshell in the download section. Do not forget that you also need to download the binutils

    Regards
    Fulvio

    #45985

    rochajoel
    Member

    Hey Fulvio, Have you corrected this issue in beta8?

    #45986

    imported_fulvio
    Participant

    Sorry, but Zeroshell is not able to manage the accounting information yet.

    Regards
    Fulvio

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.