Workaround for Freezing ALIX with WiFi

Home Page Forums Network Management Embedded Devices Workaround for Freezing ALIX with WiFi

This topic contains 2 replies, has 0 voices, and was last updated by  SysEngBD 6 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #43056

    SysEngBD
    Member

    Hello,

    I haven’t seen this in the forum, although I have seen references to systems freezing, especially with the madwifi drivers loaded. I as well as some others suspect that the madwifi drivers cause intermittent kernel panics/oops/segfaults. I have a remote WAP running Zeroshell b14 on and ALIX 2d3. It randomly freezes between twice a day and once a week, requiring a hard reboot; an issue not present on some Soekris 5501 boxes without a wireless card. If anyone is having the same issue, a small workaround is to add these two lines to the PreBoot scripts:

    echo ’30’ > /proc/sys/kernel/panic
    echo ‘1’ > /proc/sys/kerne/panic_on_oops

    The default behavior of Linux (and Zeroshell) is to wait for user input on a kernel panic, and to continue trying to operate after a kernel oops. the above lines instructs the kernel to reboot 30 seconds after a kernel panic, and in the case of an oops, to enact a kernel panic rather than continue trying to operate. Since our ALIX WAP is at a unstaffed remote site, I would prefer it to simply reboot if it runs into a kernel panic.

    Basically this has been an adequate solution as the WAP does kernel panic/oops every so often but instead of just stalling, waiting for user input at the terminal, it reboots itself and goes back into operation with users seeing an ~2 minute blip in unavailability. Further, if you don’t want the 30 second delay after the panic, you can change the lines to the following (giving a 1 second rather than 30 second delay between panic and reboot):

    echo ‘1’ > /proc/sys/kernel/panic
    echo ‘1’ > /proc/sys/kerne/panic_on_oops

    I hope someone finds this helpful as it’s cleared up some headache on my end. (I also have these lines in the main routers just in case but there hasn’t been a kernel panic on them and they haven’t been rebooted in 5 months).

    Cheers

    #51856

    mcmenkes
    Member

    Hi there,

    thanks for the info, SysEngBD !

    Indeed i have freezes as you described, but i was not sure where they come from.

    Now, after reading your post it looks very similiar to my problem.

    My specs:
    ZS Release 1.0.beta14
    [wifi0] Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
    ALIX 2d3

    Your workaround is nice and solves the manual reset, but does not the source.

    So my question to the forum: Does anybody else have these strange behaviours and how can we fix this permanently ?

    After searching around with “freeze” it seems that the problem can be isolated to Wifi / madwifi…i guess 😉

    Best regards & thanks in advance

    // MCm

    #51857

    mailsvb
    Member

    I reported this a while ago…
    http://www.zeroshell.net/eng/forum/viewtopic.php?t=1830&start=0&postdays=0&postorder=asc&highlight=

    Still not using zeroshell on that ALIX board because of this issue…

    #51858

    maxson
    Member

    i agreed with you my friend Your workaround is nice and solves the manual reset, but does not the source.

    free plagiarism checker for teachers online
    http://www.theloop21.com

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.