wildcard dns

Home Page Forums Network Management Networking wildcard dns

This topic contains 3 replies, has 0 voices, and was last updated by  brafreider 6 years, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #42484

    brafreider
    Member

    Hello,
    I´m searching for a way to setup a wildcard A-Record. I want *.domain.com to resolve to 192.168.0.4. It is possible to enter “*” as A-record for a domain but this has no effect on resolving hosts;
    afterwards “*.domain.com” resolves to the IP but yy.domain.com does not. This was not what I expected 🙂

    How can this be solved in zeroshell?

    Thanks,
    Björn

    #50640

    ppalias
    Member

    Is this possible in Bind? If you can do it in Bind, then it can be done on ZS.

    #50641

    dershao
    Member

    AFAIK it is possible in bind but I am not able to setup working wildcard entries in zeroshell.
    Has someone got this running or futher advices? Is it possible to edit the bind config manually via vi?

    #50642

    PatrickB
    Member

    Hello.

    I’m trying too because one of the stations on my LAN hosts test versions of several websites, so I need a local-domain-catch-all to send anything not explicitly known within the LAN to that station.

    So I have:

    my-domain.lan. SOA, NS etc.

    station 1 A, PTR etc.

    stationN idem

    *.my-domain.lan. A special-IP

    According to the RFC, 4.3.3:
    http://tools.ietf.org/html/rfc1034

    …where I read:

    Wildcard RRs do not apply:

    – When the query is in another zone. That is, delegation cancels
    the wildcard defaults.

    – When the query name or a name between the wildcard domain and
    the query name is know to exist. For example, if a wildcard
    RR has an owner name of “*.X”, and the zone also contains RRs
    attached to B.X, the wildcards would apply to queries for name
    Z.X (presuming there is no explicit information for Z.X), but
    not to B.X, A.B.X, or X.

    Normally imho, anything.my-domain.lan where anything contains nothing explicitly listed in the zone should match the wildcard.

    I also tried:
    *.sub.my-domain.lan. A special-IP

    But the result is always:

    RESOLVER ERROR:

    Host toto.my-domain.lan. not found: 3(NXDOMAIN)

    Has someone an idea ?

    Thanks, Best regards.

    #50643

    PatrickB
    Member

    First there is nothing usable in the named.conf, and I could not find any other text file participating in the definition of the zone. Only binary in the /DB/…

    The definition with the wildcard “*.my-domain.lan. A special-IP” persists, so it is recognized as valid by ZS’s GUI.

    Then I changed to a simple * because the resulting display (blue label) is actually
    *.my-domain.lan (without trailing dot)
    …while the full wildcard leads to
    *.my-domain.lan.my-domain.lan (this is suspect…)

    …but in any shape it does not work, always NXDOMAIN.

    According to the RFC cited above, it should, unless we fall under that restriction: “when the query name or a name between the wildcard domain and the query name is know to exist”. Here my query is not in the explicit definitions, so the wildcard should catch it.

    Then reading that:
    http://jpmens.net/2011/09/30/just-say-no-nxdomain-redirection/
    …I figured that there could be an option to enable wildcards, or a particular defintion to do, but found nothing related in what I can see of ZS.

    Is there an expert who understands it better ?
    Is it a bug ? A wanted restriction ?
    Could someone setup a workaround, not using an explicit list of subdomains to be caught ?

    Thanks, Best regards.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.