WAN interface not fecthing gateway when using DHCP.

Home Page Forums Network Management Networking WAN interface not fecthing gateway when using DHCP.

This topic contains 0 replies, has 0 voices, and was last updated by  nielsbn 6 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #43410

    nielsbn
    Member

    My internet connection comes from a small wireless company because I live in an area that doesn’t have internet in the “normal” sense… (xDSL is only 2mbit).

    So my WAN interface in my zeroshell box is set up to use “dynamic” ip assignment. I use ETH01 for my WAN and ETH00 for my lan.

    ETH00 is 192.168.100.0/24

    ETH01 is 192.168.50.0/24

    However the gateway on ETH01 is 192.168.50.252, don’t ask my why they have chosen this, but thats just how it is.

    When I used zeroshell without netbalancer activated my connection works fine and the routing table reflects that the correct GW is taken from the ETH01 connection and passed to the default route. I have also enabled NAT on ETH01 just so you know that 😛

    But when I enable netbalancer.. (yes, I have only 1 WAN connection atm. but I am fitting an 4g router aswell to balance the two lines and in the future I alm going to used VPN aggregation to speed up my stuff).

    So.. when I enable netbalancer and add my ETH01 to the list, and only selecting an INTERFACE as the gateway interface, things stop working as somehow the netbalancer cannot figure out to use the gatewat on ETH01 from DHCP.

    If I change the method to NOT use and interface, but insted manually enter the gateway address 192.168.50.252 it works fine.

    Is this by design? Or is there a fix somewhere so that I can have a completely dynamic netbalancer while only specifying interfaces?

    Thanks in advance 🙂

    #52414

    redfive
    Participant

    Hi , you cannot use the exit-interface as argument in a broadcast network (to which peer to send the frames?),while the second method should be ok , default gateway for broadcast network (hoping your isp doesn’t change the def-gw ip address!! ) and exit-interface for ppp link.
    cheers
    jonatha

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.