VPN connection’s Parameters field use for –auth-user-pass

Home Page Forums Network Management ZeroShell VPN connection’s Parameters field use for –auth-user-pass

This topic contains 1 reply, has 0 voices, and was last updated by  misterplow 9 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #42552

    misterplow
    Member

    My ZS server requires a user/password combination as well as the key to connect. Does anyone have an idea how to use the –auth-user-pass openvpn option in the zeroshell GUI? I have it working in both the Windows and Linux incarnations of the openvpn connection file.

    What I want to have in the GUI “Parameters” field is this:
    –auth-user-pass /Database/namepass.txt

    but I get a Configuration ERROR and the error log shows:

    14:42:03 OpenVPN 2.1.1 i586-pc-linux-gnu [SSL] [LZO2] [EPOLL] built on Jun 11 2010
    14:42:03 Sorry, ‘Auth’ password cannot be read from a file
    14:42:03 Exiting

    I’ve tried putting the namepass.txt (a file with the username and password each on its own line) in several places in the database but that didn’t work. The only other place I can think of is in the same directory as the openvpn binary, but that is a read-only file system that I can’t write to.

    I need a way to automatically pass the username and password credentials of the zeroshell client to the zeroshell server.

    #50816

    ppalias
    Member

    I think that the error reported is pretty clear. If you don’t want to input user-pass, use only certificates for authentication.

    #50817

    misterplow
    Member

    I think I misunderstood the (English) meaning of the error message.

    When it said it “cannot be read from a file”, I though it meant “I cannot find the file”.

    I did a little more digging around and found that the openvpn binary (on zeroshell) would have to be built with the “–enable-password-save” option in order to accommodate what I want to do, but that’s not the case so I’ll have to find another way to do what I want.

    Thanks.

    (see http://openvpn.net/archive/openvpn-users/2005-01/msg00349.html )

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.