VPN / BONDING DSL: HELP!!!!!

Home Page Forums Network Management Networking VPN / BONDING DSL: HELP!!!!!

This topic contains 1 reply, has 0 voices, and was last updated by  rgoerner 6 years, 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #43434

    rgoerner
    Member

    Hi, first I want to thank the author of Zeroshell for his great work and all guys writting here to support each other.

    I worked nearly the whole weekend and got several problems solved already. Nevertheless, still not working in that kind I would like to have it.

    I will try to provide as many information as possible for you.

    What I want to do: I have 2 sites. One with 2 x DSL uplinks and one in the datacenter. I now want to bond both DSL lines over VPN to increase bandwidth in our office.

    So that I did:

    a) On the server in the datacenter with Gigabit-Uplink, I setup 2 ip-adresses (why later) and configured 2 VPN-Servers, one on IP 1 on Port 1195, one on IP 2 on Port 1196. Both IPs are public.

    b) On the server in the office it is a little bit more tricky. I reconfigured our modems to just bridge it so that I can connect both lines over PPPoe. This works fine (after I found a bugfix here to connect well – thx). Connecting over PPPoe works well.

    c) Then I setup 2 static routes, each using one of the IPs of the VPN server in the datacenter and 255.255.255.255 netmask and of course ppp0 or ppp1 for second ip for interface. works well, too. that means VPN 1 – tracepath goes over ppp0, VPN 2 – tracepath over ppp1. Works well.

    d) On Server in office, I enabled Netbalancer (Loadbalancing and Failover) and activated both ppp links. They were used as gateways for the openvpn Lan 2 Lan Connection – working well, too.

    e) I used bonding interface on both side to bond both vpn, and gave 192.168.106.1 on the on, 192.168.106.2 on the other side. works well, too – vpn is connected over bonding, ping (pong) 😉 works well, too

    f) In netbalancer menu on side at office, I created the rule for my networkinterface where the machine is connect in our local lan and I choose Gateway for outbound. Not working, just loadbalancing, no bonding

    g) I deactivated and activated Netbalancer (both was tried) to tell the fu…. box 😉 to route using 192.168.106.2 of the VPN at the datacenter. It worked, BUT: extremly slow (we have 2 x 16 M – I got 4 M at max to each desttination). It is not problem of destination: If I log in on box in datacenter, and when I use wget to perform Download (same URL) it works great :(. Also, if I killed one of both lines, download was crashing – this should NOT happen using VPN.

    Do you can give me any hint before coming crazy?
    Thank you,
    Ronny

    #52449

    rgoerner
    Member

    One additional thought: I enabled NAT on the bond + incoming networkinterface (on that the local office server is connected to our local net), NOT to PPP0 + 1 – because this is not nessescarry. maybe i should disable that for both interfaces , too, because then maybe the netbalancer rules can work then?!?

    #52450

    m_elias
    Member

    How’s your project progressing?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.