vmware nics bridged, nat, or host

Home Page Forums Network Management Linux and Networking vmware nics bridged, nat, or host

This topic contains 2 replies, has 0 voices, and was last updated by  kingjm 10 years, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41259

    kingjm
    Member
                               Internet (eth1)(DHCP)
    |
    | vmnet0 Bridged to eth0
    | / vmnet1 Bridged to eth1
    Ubuntu - vmware < vmnet8 Hostonly
    | vmnet2 Nat 192.168.2.0
    | vmnet3 Nat 192.168.3.0
    Switch (eth0)

    I am new to zeroshell, and think that this will suit my needs. Could someone please help me put things into the correct place. I want to put zeroshell as the dhcp/firewall/gateway in place to give ip address to the switch and perhaps even the other vmnets (traffic shaping). But at moment more interested in switch.

    vmnet1 is bridged to outside to get through to internet.
    vmnet0 is bridged to eth0 to give ip addresses to switch.

    This is where I get lost. Do I need to give eth0 on ubuntu the ipaddress 192.168.1.1? How does zeroshell use this as the gateway?

    Could someone please put me in the right direction. I am sure that this is not new I just can’t seem to find my answer on the forums. Perhaps I am searching for the wrong things.

    #47067

    kingjm
    Member

    What if I give:
    Ubuntu eth0 ip: 192.168.1.1 and zeroshell vmnet0 ip:192.168.1.2

    Then set gateway to 192.168.1.254?

    UPDATE

    I gave the ETH00 ips 192.168.1.2 and 192.168.1.0
    note ETH01 is 71.x.x.58 (dhcp)

    as per http://www.zeroshell.net/eng/forum/viewtopic.php?t=686&highlight=gateway+added

    but still cannot reach outside world

    I know that it is connected to the internal because dhcp works and I can receive ipaddresses 192.168.1.100 to 150

    #47068

    kingjm
    Member

    I may have figured out part of the problem with the vmnets and using zeroshell the router. If you set the vmnetX to none then no vmware dhcp will be enabled. Then ifconfig on the ubuntu side and give vmnetX a designated ip address.

    http://communities.vmware.com/thread/45048

    Should be noted that I have not tested this at this time and this is theory to me at this point. but wanted to make a note for later use.

    #47069

    kingjm
    Member

    I have figured it out.

    both sides are bridged. The problem was that you have to disable dhcp on all interfaces. Then create a static ip on the internal interface (usually ETH00) then bring up dhcp on ETH01. The Default gateway is then chosen for you. Next go to the NAT menu and select ETH01.

    Voila it is working.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.