VLANs on BOND device lost after reboot

Home Page Forums Network Management Signal a BUG VLANs on BOND device lost after reboot

This topic contains 0 replies, has 0 voices, and was last updated by  The_Deacon 7 years, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #43166

    The_Deacon
    Member

    We have two e1000 NICs bonded, and a number of VLANs defined over the resulting BOND00 interface. This works great, until a reboot. When our zeroshell system reboots, it logs the following message, once for each VLAN we try to create:

    8021q: VLANs not supported on BOND00

    and refuses to create the VLANs. However, if I manually run the /root/kerbynet.cgi/script/iconfig script from the console once the system boots, the interfaces and VLANs are all configured correctly.

    Here is a snippet of my kernel log from when the VLANs fail to be created:

    Ethernet Channel Bonding Driver: v3.2.5 (March 21, 2008)
    bonding: MII link monitoring set to 100 ms
    e1000: ETH01: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
    802.1Q VLAN Support v1.8 Ben Greear
    All bugs added by David S. Miller
    8021q: VLANs not supported on BOND00
    8021q: VLANs not supported on BOND00
    8021q: VLANs not supported on BOND00
    8021q: VLANs not supported on BOND00
    8021q: VLANs not supported on BOND00
    e1000: ETH00: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
    bonding: BOND00: Unable to set primary slave; BOND00 is in mode 0
    bonding: BOND00: enslaving ETH01 as an active interface with a down link.
    e1000: ETH01: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
    bonding: BOND00: link status up for interface ETH01, enabling it in 30000 ms.
    bonding: BOND00: link status definitely up for interface ETH01.
    Warning: /proc/ide/hd?/settings interface is obsolete, and will be removed soon!

    Any ideas on how I can make this work correctly after a reboot, without requiring manual intervention every time?

    #52005

    The_Deacon
    Member

    Replying to myself in case others have similar problems.

    I can at least get the interfaces to come up if I enable execution of /etc/rc.local (“Post Boot”) via the web interface, and add the following line to it:

    /root/kerbynet.cgi/scripts/iconfig

    At least this brings the interfaces up. Although the root of the problem is still there — because the interfaces don’t come up when they should, services such as DHCP fail to start and have to be manually restarted. At least I don’t have to be at the console to restart them, though, and adding another line or two to /etc/rc.local isn’t too bad. But it’s an ugly hack!

    Still curious if anyone knows why the VLANs won’t work on the bonded interface, or where else in the boot process to try to fix this.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.