VLAN and DHCP

Home Page Forums Network Management Networking VLAN and DHCP

This topic contains 1 reply, has 0 voices, and was last updated by  misterph 9 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #42242

    misterph
    Member

    Hi,

    I’m very new to VLAN’ing. I’ve brought myself a Linksys SRW2008 8 Port managed switch to help me learn.

    My target is to cfg several Wireless AP’s broadcasting 2 SSID’s. (Guest Portal Access | Business) and have a portal setup for guests. I’ve got a simple setup using 2NIC’s in my ZS server.

    ETH00 1000Mb/s Full Duplex
    Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

    ETH01 100Mb/s Full Duplex
    VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)

    If I enable DHCP on either of the interfaces it works fine individually. I can plug a pc into either one and I can get issued an IP address. However, the problem I get is when I try introducing VLANS.

    SRW2008 managed switch setup

    Port 1 [TRUNK] — > ETH00

    Port 2 [Access] —-> VLAN Untagged Port [PVID = 1]

    Port 3 [Access] —-> VLAN Untagged Port [PVID = 2]

    In ZeroShell I’ve created a VLAN on ETH00 called VLAN2 with an ID of 2 and assigned an IP address to it [10.12.44.1/24] . I then goto DHCP, select the Interface [10.12.44.1/255.255.255.0 VLAN2], give it a range and save it (10.12.44.10 > 10.12.44.20).

    I then assumed that if I plugged a PC into Port 3 on my switch, the pc would get an IP address of 10.12.44.10.

    Am I missing something here? I’ve factory reset my switch incase its something in there?

    Many thanks for any suggestions, I’m trying to learn along with my CCNA course.

    Phil

    #49767

    ppalias
    Member

    Your thinking is correct. Make sure that the configuration you have done on the switch is correct. Maybe you need to specifically allow specific VLANs on the trunk port.

    #49768

    misterph
    Member

    Ok thanks for your advice. I think your right, i’ll go back to the switch and have a look at the settings.

    As long as I know my NIC’s in my ZeroShell server aren’t compatible or something silly.

    Thanks

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.