Unable to login to Web GUI

Home Page Forums Network Management ZeroShell Unable to login to Web GUI

This topic contains 1 reply, has 0 voices, and was last updated by  marc 11 years, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #40611

    marc
    Member

    Hi…

    My ZeroShell server has been running for about 1 month. The last time I logged into the GUI was about 2 weeks ago. Today I tried logging in again, but keep getting the message “Login failed!!!”.

    I login using username “admin” and the password that I set. In order to be sure of the password, I even ssh-ed into the machine and changed the password like this:

    > kadmin.local
    > cpw admin
    Enter new password: ********
    Re-enter new password: ********
    > q

    What am I doing wrong/what is going on?

    Marc.

    #45310

    marc
    Member

    I have been doing some more investigating and am getting a step closer.

    I noticed that it has to do with closing down the firewall. If I enable tcp port 443 in the INPUT chain and then go to use the web interface, I get to the login screen. However, when I login it will tell me “Login failed!!!”. When I have the firewall completely open, I can login.

    The question then becomes: with respect to firewall configuration, other than port 443, what other rules are required to make the web interface work?

    Marc.

    #45311

    marc
    Member

    Hi all,

    I found that if I allow all traffic to and from the loopback interface I can login to the web interface again.

    Any thoughts on if this is a secure way of doing things?

    Marc.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.