Sun QFE – slot binding and mac setting

Home Page Forums Network Management Networking Sun QFE – slot binding and mac setting

This topic contains 1 reply, has 0 voices, and was last updated by  r1vver 3 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #44431

    r1vver
    Participant

    I have Sun QFE 501-4366 NIC which i want to use in Zeroshell box on LAN side.

    1st problem is that Sun QFE NICs change mac address random on every boot.
    I know it’s possible to “fix” it in common linux, using 70-persistent-net.rules like here http://7200emu.hacki.at/viewtopic.php?p=27124&sid=c8f53157a7e430aa80b987d151868b3f#27124 or here http://ubuntuforums.org/showthread.php?t=2168431

    In Zeroshell i can use pre-boot script which give similar result 😳 :

    ip link set dev eth0 down
    ip link set dev eth1 down
    ip link set dev eth2 down
    ip link set dev eth3 down
    ip link set dev eth0 address 00:03:BA:11:22:4A
    ip link set dev eth1 address 00:03:BA:11:22:4B
    ip link set dev eth2 address 00:03:BA:11:22:4C
    ip link set dev eth3 address 00:03:BA:11:22:4D
    ip link set dev eth0 up
    ip link set dev eth1 up
    ip link set dev eth2 up
    ip link set dev eth3 up

    What i also want to do – is to bind NIC (eth) numbering to the PCI(e) slot (I have more than 1 NIC in my ZS box). I know it’s possible to do it also via 70-persistent-net.rules like here http://ask.debian.net/questions/how-to-bind-ethernet-nic-numbering-with-pci-e-slot

    So, question: how to do it right way in Zeroshell?

    #53948

    r1vver
    Participant

    ok, how to prevent module sunhme loading?
    I edited /grub/grub.cfg on first partition (like here https://www.zeroshell.org/forum/viewtopic.php?p=13917#13917 ) so now it’s

    root@zeroshell ~> cat /proc/cmdline
    BOOT_IMAGE=/1/3.18.21-ZS/vmlinuz root=HD=ZS-EA26E021_3.4.0_1 quiet rdblacklist=sunhme

    but sunhme is still loading 😥

    #53949

    r1vver
    Participant

    nevermind, it’s need to be modprobe.blacklist=sunhme 😀

    And finally problem#1 is kinda solved:
    1. add modprobe.blacklist=sunhme to /grub/grub.cfg on first partition
    2. create file /Database/modprobe.d/sunhme.conf with content:
    options sunhme macaddr=0x00,0x03,0xba,0xa1,0xb1,0xc1
    3. add to preboot:
    cp /Database/modprobe.d/sunhme.conf /etc/modprobe.d/
    modprobe sunhme

    ugly, but kinda working 😳

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.