Sonos & multicast relay between vlan [SOLVED]

Home Page Forums Network Management Bridges and Routers Sonos & multicast relay between vlan [SOLVED]

This topic contains 2 replies, has 0 voices, and was last updated by  digiwiz 9 months, 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #44925

    digiwiz
    Member

    Hello,

    I’m very happy with zeroshell. I’m running it for several years, and it rocks!
    However, I have a need that I’m not able to find in Zeroshell.
    I have a setup with several vlan at home:
    vlan6: “secure vlan”
    vlan212: adsl1
    vlan7: adsl2
    vlan8: guest users

    I have currently my SONOS speakers that are in the secure vlan zone, it’s working fine with controlers (application that control sonos).
    Unfortunatelly when, I use the controller in another vlan, i cant see my sonos speaker.
    I found the reason why in Sonos forums: multicast must be routed beetween vlans. I did not find how to do it in zeroshell 🙁

    There’s a fix/tool in linux aiming through this GIT:
    https://github.com/alsmith/multicast-relay
    Is that something we can integrate in the next release of zeroshell?

    Did someone manage to have sonos routing between vlans working already?
    Thanks in advance!

    #54663

    alsmith
    Member

    Thanks for highlighting this issue – the reason why it isn’t working is that the code as it stood wasn’t compatible with Python 3. I’ve pushed a couple of fixes to https://github.com/alsmith/multicast-relay – let’s see if this now works on zeroshell.

    #54664

    digiwiz
    Member

    thanks for the debug mode!
    let’s try to make it work for zeroshell 🙂

    #54665

    digiwiz
    Member

    Working!

    https://github.com/alsmith/multicast-relay

    You can now use this python script to enable multicast on zeroshell vlans !
    Therefore Sonos players / speakers will be able to work together even if there’s not in the same subnet!

    Thanks Al for the support!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.