[SOLVED]have ZS NAT maintain source address

Home Page Forums Network Management Networking [SOLVED]have ZS NAT maintain source address

This topic contains 0 replies, has 0 voices, and was last updated by  JC 5 years, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #43622

    JC
    Member

    Hey guys,

    Got a minor thing I’d like to fix, here is the story.

    Main Point:
    I am running a game server behind zeroshell on my private network, multiple connections work mostly great (there is some minor latency but that’s not a real issue for the 5 of us to deal with). I am using “Virtual Server” pointing to my game server.

    The Problem:
    When players connect to my server, on my local network coming from the internet, I lose their IP connecting to my server and the game only shows the server ip address is connecting, obviously internal clients show their correct internal ip. Is there a way to stop the changing of the source address from the users real ip to the servers ip. Do I need to setup a new Iptables chain, set a DMZ?

    thanks

    JC

    Issue was invalid settings in NAT, from a previous setup.

    #52717

    pddm
    Member

    Have you enabled NAT on the LAN NIC?
    NIC having NAT enabled will Masquerade (show the zeroshell ip address connecting).

    Removing the NIC from the NAT will show the real IP address.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.