Solution for Huawei E367 3G dongle on Zeroshell

Home Page Forums Network Management ZeroShell Solution for Huawei E367 3G dongle on Zeroshell

This topic contains 9 replies, has 0 voices, and was last updated by  gcams 4 years, 11 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #43019

    gcams
    Member

    Hi All,

    I’ve received a lot of help over the past couple of years on these forums so I thought I’d post this solution in the hope that it assists somebody else.

    ThreeUK have recently released a new “Premium” HSPA+ dongle; model Huawei E367. This is an excellent quality dongle with external antenna connector, so I was keen to get it going on Zeroshell to replace my ZTE dongles.

    Here’s how I did it:

    Step 1 – Add the required usb_modeswitch config for the E367:

    Add the following lines to the end of the /etc/usb_modeswitch.conf file:

    ########################################################
    # Huawei E367

    EnableLogging=1

    DefaultVendor= 0x12d1
    DefaultProduct=0x1446

    TargetVendor= 0x12d1
    TargetProductList="1001,1406,140b,140c,1412,141b,14ac,1506"

    CheckSuccess=20

    MessageEndpoint= 0x01
    MessageContent="55534243123456780000000000000011062000000100000000000000000000"

    Step 2:

    Run the usb_modeswitch command:

    root@zeroshell root> usb_modeswitch

    Step 3 (May not be required):

    If you have another USB serial device connected to your Zeroshell appliance, you will need to unload the usbserial module by running “rmmod usbserial” or even easier, just unplug the other serial device device to unload the usbserial driver.

    You can confirm this has been done successfully, by running the “lsmod” command and seeing if the usbserial module is in the list. As long as it’s not present, you can proceed.

    Step 4:
    Run the modprobe command to insert the usbserial module and bind to the E367’s serial ports:

    root@zeroshell root> modprobe usbserial vendor=0x12d1 product=0x1506

    Step 5:
    Confirm the driver has loaded and created the ttyUSB* devices by running “ls /udev/ttyUSB*

    If you’re successful, you should get output similar to the below:

    root@zeroshell root> ll /udev/ttyUSB*
    crw-rw---- 1 root root 188, 0 Jun 6 14:53 /udev/ttyUSB0
    crw-rw---- 1 root root 188, 1 Jun 6 14:51 /udev/ttyUSB1
    crw-rw---- 1 root root 188, 2 Jun 6 14:51 /udev/ttyUSB2
    crw-rw---- 1 root root 188, 3 Jun 6 14:53 /udev/ttyUSB3

    Step 6:

    Finally, configure your new PPP device as normal through the web interface. You will need to use /udev/ttyUSB0 as the actual modem device for establishing the PPP connection. ttyUSB1 and 2 appear to have no functionality (you cannot communicate with the modem via them) and ttyUSB3 is the “management” interface. This allows you to query signal strength (at+csq, etc) while the modem is online.

    I hope the above is of assistance to somebody. Maybe the above changes could be incorporated into the next release, to avoid having to take the above steps on each boot? I now use a small bash script to automate the above steps:

    #!/bin/bash

    cd /Database/extradata

    # Copy modeswitch config file to /etc
    echo '########################################################
    # Huawei E367

    EnableLogging=1

    DefaultVendor= 0x12d1
    DefaultProduct=0x1446

    TargetVendor= 0x12d1
    TargetProductList="1001,1406,140b,140c,1412,141b,14ac,1506"

    CheckSuccess=20

    MessageEndpoint= 0x01
    MessageContent="55534243123456780000000000000011062000000100000000000000000000"' >> /etc/usb_modeswitch.conf


    # Run modeswitch command
    usb_modeswitch

    # Run modprobe command
    modprobe usbserial vendor=0x12d1 product=0x1506
    #51799

    Zeqro
    Member

    fluvio could just update the version of usb_modeswitch to a new version 🙂

    If only I was a bit more adapt at Linux I could have probably compiled and added the updated module myself :'(

    Thanks for the post btw. The Huawei settings you posted are valid for a number of their modems and worked fine with two I used (e175 and the e363).

    #51800

    gcams
    Member

    I’m glad the post was helpful Zeqro. Yes it would be good to have an updated version of usb_modeswitch in zeroshell, which would support the new dongles natively.

    Good to hear that my fix works with the new E175 too though! That’s handy to know!

    #51801

    Zeqro
    Member

    gcams, I don’t know how silly this sounds but can you help me with the following?

    When I create a post boot script and save my profile it’s not loaded up on restart. In fact the script is deleted and the files saved inside the Database are deleted.

    I understand that this is happening because my files / settings aren’t being saved. But where do I need to set the option to save them then?

    What I tried to do is do all the settings and then save the profile but this didn’t seem to do anything useful. On the main page (zeroshell.net) the FAQ say you need to go to Setup -> Storage on the web interface but I cannot find that anywhere…

    Hope you can help.

    #51802

    Dave.R
    Member
    gcams wrote:
    Hi All,

    I’ve received a lot of help over the past couple of years on these forums so I thought I’d post this solution in the hope that it assists somebody else.

    ThreeUK have recently released a new “Premium” HSPA+ dongle; model Huawei E367. This is an excellent quality dongle with external antenna connector, so I was keen to get it going on Zeroshell to replace my ZTE dongles.

    Here’s how I did it:

    Step 1 – Add the required usb_modeswitch config for the E367:

    Add the following lines to the end of the /etc/usb_modeswitch.conf file:

    Code:
    ########################################################
    # Huawei E367

    EnableLogging=1

    DefaultVendor= 0x12d1
    DefaultProduct=0x1446

    TargetVendor= 0x12d1
    TargetProductList=”1001,1406,140b,140c,1412,141b,14ac,1506″

    CheckSuccess=20

    MessageEndpoint= 0x01
    MessageContent=”55534243123456780000000000000011062000000100000000000000000000″

    Step 2:

    Run the usb_modeswitch command:

    Code:
    root@zeroshell root> usb_modeswitch

    Step 3 (May not be required):

    If you have another USB serial device connected to your Zeroshell appliance, you will need to unload the usbserial module by running “rmmod usbserial” or even easier, just unplug the other serial device device to unload the usbserial driver.

    You can confirm this has been done successfully, by running the “lsmod” command and seeing if the usbserial module is in the list. As long as it’s not present, you can proceed.

    Step 4:
    Run the modprobe command to insert the usbserial module and bind to the E367’s serial ports:

    Code:
    root@zeroshell root> modprobe usbserial vendor=0x12d1 product=0x1506

    Step 5:
    Confirm the driver has loaded and created the ttyUSB* devices by running “ls /udev/ttyUSB*

    If you’re successful, you should get output similar to the below:

    Code:
    root@zeroshell root> ll /udev/ttyUSB*
    crw-rw—- 1 root root 188, 0 Jun 6 14:53 /udev/ttyUSB0
    crw-rw—- 1 root root 188, 1 Jun 6 14:51 /udev/ttyUSB1
    crw-rw—- 1 root root 188, 2 Jun 6 14:51 /udev/ttyUSB2
    crw-rw—- 1 root root 188, 3 Jun 6 14:53 /udev/ttyUSB3

    Step 6:

    Finally, configure your new PPP device as normal through the web interface. You will need to use /udev/ttyUSB0 as the actual modem device for establishing the PPP connection. ttyUSB1 and 2 appear to have no functionality (you cannot communicate with the modem via them) and ttyUSB3 is the “management” interface. This allows you to query signal strength (at+csq, etc) while the modem is online.

    I hope the above is of assistance to somebody. Maybe the above changes could be incorporated into the next release, to avoid having to take the above steps on each boot? I now use a small bash script to automate the above steps:

    Code:
    #!/bin/bash

    cd /Database/extradata

    # Copy modeswitch config file to /etc
    echo ‘########################################################
    # Huawei E367

    EnableLogging=1

    DefaultVendor= 0x12d1
    DefaultProduct=0x1446

    TargetVendor= 0x12d1
    TargetProductList=”1001,1406,140b,140c,1412,141b,14ac,1506″

    CheckSuccess=20

    MessageEndpoint= 0x01
    MessageContent=”55534243123456780000000000000011062000000100000000000000000000″‘ >> /etc/usb_modeswitch.conf

    # Run modeswitch command
    usb_modeswitch

    # Run modprobe command
    modprobe usbserial vendor=0x12d1 product=0x1506

    Hi man you said you used ZTE can you please name the model you used and the way you configured it to work with zeroshell .
    thanks allot ,

    #51803

    Zeqro
    Member

    Dave you can find updated lists for a lot of models on http://www.draisberghof.de/usb_modeswitch/device_reference.txt

    This is where gcams got his info from I presume as well.

    Which model are you looking for? I use both the ZTE K3850-Z and the K3570-Z.

    Do you need configuration details for those?

    #51804

    gcams
    Member
    Dave.R wrote:
    Hi man you said you used ZTE can you please name the model you used and the way you configured it to work with zeroshell .
    thanks allot ,

    Hi Dave, the model of ZTE I have is an MF112 HSUPA dongle. It was very simple to setup.. you just need to eject the virtual CD-ROM device that mounts when the dongle is plugged in, to get it to modeswitch (i.e. on mine I need to eject /dev/sr0). This causes the USB serial ports to show up.

    The only trick was I needed to copy the eject command from a linux distro, as Zeroshell doesn’t have it installed by default. I think I used the eject binary from one of the later fedora distributions and it worked fine.

    I hope that is of some help??

    Cheers,
    Graham

    #51805

    gcams
    Member
    Zeqro wrote:
    gcams, I don’t know how silly this sounds but can you help me with the following?

    When I create a post boot script and save my profile it’s not loaded up on restart. In fact the script is deleted and the files saved inside the Database are deleted.

    I understand that this is happening because my files / settings aren’t being saved. But where do I need to set the option to save them then?

    What I tried to do is do all the settings and then save the profile but this didn’t seem to do anything useful. On the main page (zeroshell.net) the FAQ say you need to go to Setup -> Storage on the web interface but I cannot find that anywhere…

    Hope you can help.

    Really not too sure what would be causing this!? I haven’t seen this behaviour on my Alix setup running off a compact flash card and I don’t really know enough about how Zeroshell deals with it’s filesystems to be able to troubleshoot it for you. Sorry! Hope you manage to get it sorted.

    #51806

    Zeqro
    Member

    Yeah it is weird. It works fine when booting from a USB stick.

    Seems that it writes fine when loading off a medium to which you can actually save your profile to.

    But I’ve also got it to work on a machine with a CD bootable system as well, at times that is. I guess I’m just not familiar enough with how Linux works in this aspect.

    I know this is the wrong place to ask, but I seem to be stuck on my VPN lan to lan. I’ve got my VPN server connected to my router and portforwarded all ports to the VPN server.
    The bonds at both ends are on a different subnet from the router subnet but when I create a static route on the VPN server to route all traffic from the bond subnet to the router subnet I can’t access the client from another machine connected to a router on the VPN server side. But I can see the client from the VPN server only…

    I hope that didn’t sound confusing?…

    #51807

    rfkiki
    Member

    Useful and great ,thank u !

    #51808

    tracys
    Member

    Hello All,

    I am looking ZTE K3570-Z and mf631 setting.

    Anyone can help me

    Tracy

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.