Sierra Modem MC8780 and obsolete driver

Home Page Forums Network Management Signal a BUG Sierra Modem MC8780 and obsolete driver

This topic contains 4 replies, has 0 voices, and was last updated by  raf 9 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #42275

    raf
    Member

    (this is the translation of this post:
    http://www.zeroshell.net/forum/viewtopic.php?t=2287&sid=894a3436468e7f720c3de4d6b4bd7075
    )

    I installed the MC8780 modem in a Alix 6e1 motherboard.
    Three port are recognized: ttyUSB0, ttyUSB1, ttyUSB2.
    ttyUSB1 cannot be used but this is normal since it is a control port.

    If I use ttyUSB2 as data port, apparently it all works but I just discovered that it should *not* used for these reasons:
    1. Additional commands like AT+COPS are rejected from the modem (ERROR). This is because they should be issued to the ttyUSB0 port.
    2. comgt that is normally used to obtain quality info and other stuff during communication, cannot be used. comgt should be used against the control port (ttyUSB2) but this is actually used for data from PPPD process.
    3. Sierra Wireless say that data throughput is much lower on ttyUSB2 and performance are bad.
    This is the link of a Sierra developer that talks about the problem:
    http://www.gossamer-threads.com/lists/linux/kernel/1048004?do=post_view_threaded#1048004

    From the previous link it’s clear that the right choice for PPPD is ttyUSB0. Sadly any test to configure this port for data communication fails (look at chat log for details) while sending the command AT+CGDCONT.

    I believe that the problem solution is very simple. The current Zeroshell release is using a very old (obsolete) Sierra driver.
    The official newer Sierra driver is here:
    http://sierrawireless.custhelp.com/app/answers/detail/a_id/500/~/can-i-use-my-sierra-wireless-modem-on-a-linux-operating-system-%3F-(-v.1.7.30)
    There you can find drivers and PPP scripts, and this should be the definitive solution.

    Apparently the solution is to rebuild the kernel+driver with the latest version, also updating the scripts.

    Thanks for the great job,
    Raffaele

    #49884

    hminkoong
    Member

    Dear raf

    I’ve found the same problem as yours .
    I’ve already upgrade the driver to v.1.7.30.
    However i still can’t connect to port /udev/ttyUSB0.
    Don’t know why?
    Can you find other solutions for this problem ?

    Best Regards
    Hminkoong

    #49885

    raf
    Member

    Hi Hminkoong,
    I also upgraded the driver and it didn’t apparently help.
    But I solved the problem anyway.
    There are two main problems that Sierra Modem does not handle as many others:
    1. You don’t have to store an AT+COPS command in the profile. Please reset it with AT+COPS=0 and store the configuration in the profile
    If you don’t do this, any IP connection will fail both on USB2 and USB0 (you will not receive any IP Address).
    2. If you want to use USB0, you will have to do this steps:
    A. store the APN in the profile and then use *99***1# instead of *99#
    The “1” in that string is the profile number where the APN is stored.
    B. go in the root/kerbynet.cgi/scripts folder and edit 3Gconnect script
    change the string from:
    “OK” “ATD$DIAL”
    to:
    “ERROR” “ATD$DIAL”
    The first string (OK/ERROR) is the one expected after the script send the APN. So you will wait the “ERROR” string in order to go on 🙁
    Sierra Modems apparently does not accept the APN on the USB0.
    Please note that this change is a bad procedure since resetting zeroshell will restore the original script. You should modify the template instead. (I did not have time for that).
    Remember to store the APN in the profile using minicom to the USB2 port.

    There are many extended commands in this modem. To understand that you need the official docs and password from a Sierra reseller. Otherwise try to google for them. They are under NDA, so I can’t talk about them.

    #49886

    hminkoong
    Member

    Dear raf

    Thank you so much raf.
    Finally i can connect to a real data port “ttyUSB0”.

    Best Regards
    Hminkoong

    #49887

    raf
    Member

    You’re welcome.
    If you or anyone else has any suggestion on modifying in a cleaner way the scripts, that would be great.
    For “cleaner” I mean:
    – what template should be modified so that it is not erased after reboot
    – how to send the APN anyway (so that the script will work also on USB2) and ignore the “ERROR” or “OK” string.

    Finally. The througput here in Italy is really a mess. I have no more than 1MB/s as a result on speedtest.net website (“tre” provider).
    I know that “3G” is only a marketing word for italian providers, but I want to be sure that the other settings are ok. How fast are you going on that website?

    Thanks

    #49888

    hminkoong
    Member

    Dear raf

    These are the steps that i did against the Zeroshell from earasing the file after next reboot.
    1. I modified the script “3Gconnect” as you suggested (change string from “OK” “ATD$DIAL” to: “ERROR” “ATD$DIAL” ). and i copied it to /Database/preboot (i havet to create “preboot” directory first).
    2. Then i put the command “cp /Database/preboot/3Gconnect /root/kerbynet.cgi/scripts/3Gconnect -a” into a preboot script area.

    At Some area, My sierra modem can connect the internet at the speed almost 3.5 mb/s
    Now I’m living in Thailand.

    Best Regards
    Hminkoong

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.