Settings for a router?

Home Page Forums Network Management ZeroShell Settings for a router?

This topic contains 1 reply, has 0 voices, and was last updated by  Terabyte 9 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #41947

    Terabyte
    Member

    Hi,

    I’ve been followng a couple of tutorials on the internet for setting up a router and can’t get it to work.

    I’ll explain my setup:

    2 network cards, one plugged into a modem (pre configured ages ago), one plugged into another computer (plan to change to a switch later if this works).

    ETH0 is connected to the internet.
    ETH1 runs to my computer.

    So far all I’m able to do is access the zeroshell config page, I’m unable to access pages on the internet.

    I believe i”ve setup DHCP correctly since I’ve been assigned an IP address in the correct range.

    My routers address is now 192.168.0.1, my computers address is 192.168.0.100.

    My internet address info is:
    IP: 78.86.172.102
    SUBNET: 255.255.240.0
    GATEWAY: 78.86.160.1

    It’s a static IP for ADSL.

    I am sure these settings are correct since a single machine can access the internet directly using these settings, just not when behind my zeroshell router.

    I’ve attached two screenshots.
    I’m not sure if any of the settings shown in those screenshots are correct.
    I was told to make a bridge, then I was told since the local network ip’s wern’t routable, to delete this bridge and instead go to NAT and shift over the subnet (not sure which one, presumably eth1 since that’s my local computer) to the NAT side of the page. But this hasn’t made it work either.

    Also I am confused as to what to set the default gateway as on the router, presumably 78.86.160.1 right?

    Additionally if i click “edit” on the entry in static routes which gets created if i set a default gateway, I don’t know what to make of the “Destination” and “Netmask” entries contained here.

    I don’t even know if I was supposed to add both 192.168.0.1 and 78.86.172.102 to eth0 with nothing under eth1. I just “added an ip” following a tutorial.

    Could somebody let me know what the settings should be and what I need to change?

    The screenshots reflect the current state of things
    http://img7.imageshack.us/img7/4039/networkandgateway.jpg
    http://img7.imageshack.us/img7/3881/routernat.jpg

    #48843

    JC
    Member

    ok, is your modem acting as a router? when u set up ZS u should use it to connect to the internet, make a PPPoE connection off your ETH0, NAT will auto set itself, u dont need to set a gateway. set DHCP on ETH1 for your network. u shouldnt have a realworld and a local IP on the same ETH device.

    there are great walkthrus here:

    http://www.zeroshell.net/eng/documentation/

    Hope this helps
    JC

    #48844

    ppalias
    Member

    On ETH01 assign IP 192.168.0.1/255.255.255.0 and enable DHCP server for that range.
    On ETH00 you already have the public IP address. Enable NAT on interface ETH00. No bridging. No need for a static route, the Default Gateway is fine. Add a DNS server, maybe this could be a reason for not having internet. You can either use your ISP’s servers or OpenDNS.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.