Setting up Captive portal issues

Home Page Forums Network Management ZeroShell Setting up Captive portal issues

This topic contains 5 replies, has 0 voices, and was last updated by  compguy030471 9 years, 7 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #41915

    I am setting up a zeroshell server in between a dsl modem and a Switch.

    i have made ETH00 The public facing interface and ETH01 the internal interface that will hash out the DHCP scope. The switch is a POE switch and will have Cisco AP’s connected.

    I have successfully configured to the point where a wireless laptop can join the guest network, get a 10.10.10.0 DHCP address, log onto the captive portal with a created username, and gets connected. The problem from here is that I cannot get onto the internet. The zeroshell server is on the internet. It has already done updates. How do I route the DHCP traffic to ETH00?? Help!!

    #48743

    yum
    Member

    Is DSL modem in routed mode or in bridge mode? Did you setup default gateway and activate NAT on ETH00 interface?

    #48744

    Traceroute to http://www.yahoo.com by domain name first and then by IP address.
    You may be connected but have your DNS misconfigured.
    To further verify your DNS on your client use nslookup (for windows) or dig (for linux).

    #48745

    Zeroshell has an IP 0f 192.168.0.163 on Eth00, The default gateway is 192.168.0.2, and ETH01 is 10.10.10.1 with a DHCP range of 10.10.10.100-10.10.10.200. I have not setup NAT. Which interface would i do it on?

    #48746

    yum
    Member

    Under [Router] menu item select [NAT] and mark ETH00 as “NAT enabled interface”.

    #48747

    Thanks vpn_rollercoaster and yum. i will give both a look today and update whether it works.

    #48748

    I checked the DNS and the NAT suggestions. It turned out that when I placed the ETH00 interface in the NAT section it started to work flawlessly! Thanks yum and vpn_rollercoaster for your suggestions and help.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.