Sending forgotten password not working

Home Page Forums Network Management ZeroTruth Sending forgotten password not working

This topic contains 6 replies, has 0 voices, and was last updated by  Simsa 5 years, 3 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #43959

    Simsa
    Member

    Hi everyone,

    the “forgot password”-dialog ends always with: “User not found” at my site, although I’m 100% sure the user exists (I can login with this user). Is something wrong with my installation or is it a bug?

    I use Zerotruth 2.0RC2 with Zeroshell 3.0.

    Thanks, Simsa

    #53342

    truthahn
    Member

    Hi,

    I did some tests on my installations and works all.

    regards

    #53343

    Simsa
    Member

    Hi,

    thank you for your fast reply and the tests!
    So there seems to be something wrong at my site 🙁

    Maybe it is related to a problem with crontab: At boot the message: “”/tmp/crontab.XXXXYHWFfB”:7: bad day-of-week” appears.

    The crontab looks indeed quite messy: http://pastebin.com/VJFuDhBX
    Could you maybe share your crontab or a hint what I can delete/change?

    Thanks,
    Simsa

    #53344

    truthahn
    Member

    I do not think it comes to this. But it is certainly a problem.
    As you enter the user?
    Meanwhile, delete the cron-program and try to register the user.
    Then check crontab

    #53345

    Simsa
    Member

    I agree the crontab mess has nothing to do with the password change dialog, but with the cron thing is definitely something wrong. I deleted the content of crontab but when I click save under konfig -> backup all the things reappear in crontab inclusive the error message “can’t install cron: bad day-of-week”.

    UPDATE: It’s not only the backup-dialog it’s also with the register user and probably some more (I did not test more function yet).

    #53346

    truthahn
    Member

    hi,

    rm -rf /Database/var/register/system/startup/scripts/*START*
    rm -rf /Database/var/register/system/startup/scripts/*STOP*
    /DB/apache2/cgi-bin/zerotruth/scripts/zt.sh RestartCron
    #53347

    Simsa
    Member

    Hi,

    thank you, that worked very well!
    Should I now expect any disadvantages because of removing the start and stop scripts?
    For example will the backup still work?

    #53348

    Simsa
    Member

    Ok back to the actually topic: now I know why sending passwords did not work: I don’t use the send sms function, and if I don’t enter a mobile phone number but only the username and mail address, the message “Username unknown” appears.
    So it’s probably designed to work only per sms. So I think I will change the message to something like: “Your username is wrong or you forgot to enter your mobile phone number” or something similar.

    Many Greetings, Simsa

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.