secure web link

This topic contains 2 replies, has 0 voices, and was last updated by  baboo 10 years, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #40849

    baboo
    Member

    I am hoping one of you web masters might be able to give me some pointers on how to solve a problem.

    I have a website that has an employee login page. After employee logs in, a button apprears that is linked to intranet site. They click on button and now they are inside the net on the intranet.

    I wanted this to be secure, so I used https. Now when the employee logs in the button appears, but when they click on it, it times out with message can’t find server.

    Could someone tell me how to think about solving this. Do I need to do a port redirection to intranet server? Do I need to enable https on intranet?

    Hoping someone can give me some insight on how to solve.

    thanks

    #46058

    saadakhtar
    Member

    hi,
    first you need to determine what kind of web server you are running.
    lets say you are running apache, in that case you will need to enable SSL on the server itself. you can find a lot of howto’s on the web for setting up a SSL webserver.
    once the server accepts secure connections, you can go ahead and forward port 443 (standard SSL) to your server.
    hope this explaination helps.

    #46059

    Bob_Cat
    Member

    Hello,

    I have a similar problem in that inside my network I have an intranet server which I need to expose outside my network. I only want that to happen with SSL https. However the problem is that when I use the Virtual Server section and select port 443 it doesn’t map because the port is used by Zeroshell.

    Is there any way to direct traffic directed at a particular internet IP to a particular server? Something like a selective DMZ etc?

    Regards,

    Bob

    #46060

    Bob_Cat
    Member

    Correction,

    The website redirection appears when I connect from outside the office, however it does not work when I am inside the office because it diverts to zeroshell.

    How is it possible to Static NAT a host and manage it’s ports so I can avoid collisions of ports with the gateway?

    Bob

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.