RIPv2 bug in Zeroshell

Home Page Forums Network Management ZeroShell RIPv2 bug in Zeroshell

This topic contains 1 reply, has 0 voices, and was last updated by  Piduna 2 years, 1 month ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #44646

    Piduna
    Member

    eth1 – it is local network (192.168.110.0/255.255.255.0). It ip is 192.168.110.180. tap0 – OpenVPN network (192.168.112.0/255.255.255.0). eth0 – my ISP.

    In Zeroshell, i have ETH2 – local network. It ip is 192.168.110.15. ETH0 – my ISP, VPN99 – network for VPN (192.168.250.0/255.255.255.0)

    ripd.conf


    hostname ripd
    password zebra
    log stdout
    !

    interface ETH02
    ip rip authentication mode text
    ip rip authentication string termo
    ip rip split-horizon
    router rip
    redistribute kernel
    redistribute connected
    redistribute static
    network ETH02

    Why I received from zeroshell all networks? In config file, i write:
    network ETH02! Not ETH00, Not VPN99, and other. Why, zeroshell return too many networks ?

    In official documentation, i read:


    RIP command: redistribute connected
    RIP command: redistribute connected metric <0-16>
    RIP command: redistribute connected route-map route-map
    RIP command: no redistribute connected

    Redistribute connected routes into the RIP tables. no redistribute connected disables the connected routes in the RIP tables. This command redistribute connected of the interface which RIP disabled. The connected route on RIP enabled interface is announced by default.

    Ok, i need in ripd.conf change


    redistribute connected

    on


    no redistribute connected

    But how to accept this ? When, i restart Zeroshell, all it chages are canceled. How to do this ? Thanks for you attention.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.