Restrict DNS forwarding for local addresses

Home Page Forums Network Management Linux and Networking Restrict DNS forwarding for local addresses

This topic contains 0 replies, has 0 voices, and was last updated by  kyleb 9 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42052

    kyleb
    Member

    I have Zeroshell up and running.. .it’s working great! I have one small issue with DNS I’d like to resolve.

    I have Zeroshell set as the DNS resolver for all my internal computers. It gives the internal addresses for all hosts on our domain. I also have a forwarder set up for ANY domain to OpenDNS to handle other DNS.

    I would like hosts not found in our local domain to result in NXDOMAIN. However, instead, they are forwarded out to OpenDNS. Is there a way to restrict the forwarding of the local domain requests, but let all the others go out? Thanks for any suggestions you have.

    #49134

    ppalias
    Member

    What you ask is working in my setup.
    karavida is not a valid name, however rofos is.

    > karavida.trendy.awmn
    Server: [10.14.149.1]
    Address: 10.14.149.1

    *** [10.14.149.1] can't find karavida.trendy.awmn: Non-existent domain
    > rofos.trendy.awmn
    Server: [10.14.149.1]
    Address: 10.14.149.1

    Name: rofos.trendy.awmn
    Address: 10.14.149.1

    Zone trendy.awmn as well as its reverse are master in my ZS and for ANY other I forward to the DNS servers of my provider.
    My DNS options are

    recursion yes;
    allow-query {10.0.0.0/8;127.0.0.0/8;};

    Hope this helps.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.