Remote access 4G from WAN

Home Page Forums Network Management ZeroShell Remote access 4G from WAN

This topic contains 3 replies, has 0 voices, and was last updated by  DVRS 4 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #43910

    DVRS
    Participant

    Hello to everyone!

    I have installed a 4G Huawei modem on Zeroshell succefully, but just having a problem with getting public access. We only have the 4G modem for internet access and also want to have remote access to our server in the office. This is also where our problem starts, we have a dynamic WAN IP but this can be solved with OpenDNS. Below I have some details I found in Zeroshell. I am just missing something but can’t figure it out.

    NAT = ppp0
    ppp0 connected = inet 100.68.140.180 P-t-P 10.64.64.64
    ETH00 Gateway = 192.168.0.75

    #53258

    DVRS
    Participant

    20:33:35 pppd 2.4.3 started by root, uid 0
    20:33:36 Serial connection established.
    20:33:36 Using interface ppp0
    20:33:36 Connect: ppp0 /dev/ttyUSB0
    20:33:38 Could not determine remote IP address: defaulting to 10.64.64.64
    20:33:38 local IP address 100.68.140.180
    20:33:38 remote IP address 10.64.64.64
    20:49:40 Terminating on signal 15
    20:49:40 Connect time 16.1 minutes.
    20:49:40 Sent 51836 bytes, received 407356 bytes.
    20:49:40 Connection terminated.
    20:49:40 Hangup (SIGHUP)
    20:49:40 Exit.
    20:49:41 pppd 2.4.3 started by root, uid 0
    20:49:42 Exit.
    20:49:44 pppd 2.4.3 started by root, uid 0
    20:50:00 Connect script failed
    20:50:00 Exit.
    20:50:04 pppd 2.4.3 started by root, uid 0
    20:50:14 Connect script failed
    20:50:14 Exit.
    20:50:14 pppd 2.4.3 started by root, uid 0
    20:50:16 Serial connection established.
    20:50:16 Using interface ppp0
    20:50:16 Connect: ppp0 /dev/ttyUSB0
    20:50:17 Could not determine remote IP address: defaulting to 10.64.64.64
    20:50:17 local IP address 100.68.140.180
    20:50:17 remote IP address 10.64.64.64

    #53259

    redfive
    Participant

    Hi DVRS, what do you mean with “This is also where our problem starts” ? What exactly is your goal and how are you trying to reach it ? What works and what doesn’t ? I can only see that ppp interface has gone down and then is up again…and your public ip address….a bit more info would help.
    Regards

    #53260

    DVRS
    Participant

    Hi Redfive, thanks for your reply.

    We have our 4G modem working (internet) but we also want to access our office from outside. If we want to connect to our servers we need forwarding IP or VPN. The public IP we get from our ISP is dynamic (92.xxx.xxx.xxx), the 4G modem gets a local IP starting with 100.xxx and remote IP is 10.64.64.64 I think the problem is caused by the APN we have to use, but I am not sure.

    I want to know if its possible to change the modem remote/local IP settings?

    Regards,

    #53261

    DVRS
    Participant

    Issue solved, ISP uses transparant proxy.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.