recovering ldap problems

Home Page Forums Network Management ZeroShell recovering ldap problems

This topic contains 0 replies, has 0 voices, and was last updated by  Terabyte 9 years, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42011

    Terabyte
    Member

    Hi,

    I’m having severe problems with my zeroshell system,

    now when i switch it on I get:

    activating swap file… [ok]
    starting x.509 certification authority…. [ok]
    starting ldap daemon….
    recovering ldap db

    and here it stops, and waits………

    This has happened before on a brand new install that
    > ran for 3 day and >> then did that^.

    Have I forgotten to configure something?

    I note this:

    >
    http://www.zeroshell.net/eng/forum/viewtopic.php?t=1305&sid=ca10012a719e7a75f1d1ba1a94de8a86

    I havn’t setup kerberos at all, nonetheless they don’t
    > explain what in >> kerberos I have to setup, or what in
    > kerberos fixes the problem, could >> somebody point me in
    > the right direction? >>
    > >

    #49017

    hippieshaker
    Member

    I had this issue after trying to reset the admin password – ZeroShell web interface locked up and after a reboot got stuck at “Recovering LDAP DB”.
    In case anyone still having this issue, I fixed mine as follows:

    Boot to any Live CD.
    Mount the partition with the affected configuration.
    cd /mnt/sda1/_DB.001/var/openldap-data
    sudo mkdir bak
    sudo mv __.db.00* ./bak/
    sudo reboot

    ZeroShell reboots okay but not sure what part of LDAP configuration is affected.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.