Radius Server & Captive Portal Login settings?

Home Page Forums Network Management ZeroShell Radius Server & Captive Portal Login settings?

This topic contains 7 replies, has 0 voices, and was last updated by  shah 9 years, 7 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #41036

    shah
    Member

    Hi all,

    I’m a newbie here and try to get my home wifi secured via radius server. currently i have a linksys wrt54g router, modem and a server. I don’t have any spare machines for a raduis server so I set up virtual zeroshell.

    I have been reading a lot in the FAQs an documentations, but maybe i’m so dumb still can;t figure it out.

    modem < -- wifi router(192.168.1.1) < -- zeroshell(192.168.1.75)[on a physical 192.168.1.2 machine]

    router clients are on DHCP 192.168.1.100-200

    zeroshell settings

    IP 192.168.1.75
    Gateway – 192.168.1.1
    Accesspoint – 192.168.1.0/24
    DHCP – not enable
    Captive Portal – Bridgemode on ETH00

    What I really want to achieve is to have the captive portal authenticate wireless user only. However when wired user open a browser to access internet (from 192.168.1.x), i was redirected to the captive portal; once the user login the browser redirect back to internet.

    My wireless client however unable to connect as shown below

    Can anybody guide me… where did I went wrong? 😳

    btw this piece of software is awsome.. congrats to all involved guys..[/img]

    #46496

    imported_fulvio
    Participant

    You should have at least two bridged ethrnet interfaces to make Zeroshell acts by captive portal.
    In addition you have enabled WPA on your Access Point and therefore you are asked for certificate.

    Regards
    Fulvio

    #46497

    shah
    Member

    How to make 2 bridge where i only have 2 connection that is ETH00 & VPN99. 😀

    #46498

    imported_fulvio
    Participant

    You need at least two ethernet interface on which you can route or bridge traffic.

    Regards
    Fulvio

    #46499

    shah
    Member

    Thanks for the fast reply fulvio, my server is a window server, and virtual zeroshell is in this server. I have 2 ethernet cards on the server(192.168.1.2), which is being connected to the router (192.168.1.1). The other ethernet card is not in use.

    In the zeroshell image I downloaded only provide me ETH00 and VPN99. Correct me if I’m wrong, ETH00 is set on 192.168.1.75 where VPN99 i think is a bridge mode for the virtual server.

    Do I add another bridge in the zeroshell? Can I bridge VPN99 or can I add the interface in the VMX file.

    #46500

    imported_fulvio
    Participant

    In the VMWare settings you have to add another ethernet interface. When you restart Zeroshell, it automatically will see the hardware change and configure the new interface as ETH01.

    Regards
    Fulvio

    #46501

    shah
    Member

    I finally able to create the ETH01, however I can’t add ip within the same range of ETH00.

    #46502

    imported_fulvio
    Participant

    You cannot have the same subnet on more the one interface, because otherwise the routing process would be not determinated. If you need the same IP class you just have to bridge the two interface and then to assign the IP address to the BRIDGE00 interface. In this case the captive portal needs to be configured in bridge mode.

    Regards
    Fulvui

    #46503

    So if my Eth00 has an IP of 172.22.31.2 I can just bridge ETH00 and ETH01 to create BRIDGE00 and then when users open their web browser it will automatically open to the captive portal page?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.