Question about the Router in Zeroshell

Home Page Forums Network Management Networking Question about the Router in Zeroshell

This topic contains 5 replies, has 0 voices, and was last updated by  LingaringBell 10 years, 10 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #41429

    I can’t seem to get the routing functions in Zeroshell to work correctly, so I think I must be overlooking something simple. Here is what I’m doing, I have Zeroshell installed on a computer with two network cards. One network card has IP address 10.10.10.2, the other 192.168.2.2. The default gateway is 10.10.10.10, which is my router going to the internet. The router is connected to my zeroshell machine. My zeroshell machine can ping and trace out to the internet fine.

    I take a second computer with IP address 192.168.2.3 and default gateway 192.168.2.2 (the zeroshell box) and connect it to the zeroshell machine. This computer can not get to the internet and can not ping 10.10.10.10, it however, can ping 10.10.10.2 (the zeroshell box). Also, it can not get out to the internet.

    10.10.10.10 can not ping 192.168.2.3, but can ping 192.168.2.2 (zeroshell box).

    This makes no sense to me, a routers purpose in life is to connect two subnets, but this doesn’t seem to be working at all. Please someone explain to me what I’m doing wrong. Thanks.
    -Bell

    #47499

    imported_fulvio
    Participant

    You have 3 possibilities to get the routing process to work correctly:

    1) Add a static route to the Internet router to tell it to use the router 10.10.10.2 to reach the subnet 192.168.2.0/0;

    2) Enable RIP version 2 to both the routers so the routing is dynamically configured;

    3) Enable the NAT for the interface thatr has IP 10.10.10.2 (easier solution);

    Regards
    Fulvio

    #47500

    sorry i forgot to mention it, but I already have a static route on the internet router pointing it to 10.10.10.2 when looking for 192.168.2.0

    If i do a trace from the internet router to 192.168.2.3, it hops to 10.10.10.2 and then stops. For some reason it isn’t getting through the zeroshell box.

    #47501

    ppalias
    Member

    Looks like either a routing issue (better double check that the routing tables are ok) or a firewall issue (check that the internet router doesn’t block traffic coming from 192.168.2.0/24, as well as 192.168.2.3 accepts icmp).

    #47502

    I think I figured it out. The GUI doesn’t seem to properly change the routing tables if you change the Default Gateway from one network interface to the other. For example, I created the zeroshell profile originally with Default Gateway 192.168.2.3. Then, I added a second network card, and changed the Default Gateway to the new card (10.10.10.10).

    I solved the problem by just making a new profile and everything started working fine. However, if I run into this problem in the future, I’m guessing I could fix it by editing the routing tables from the Linux shell. Does anybody know a good website that talks about how to do that? Or just the commands so I can look up the man pages? Thanks.

    #47503

    imported_fulvio
    Participant

    Are you sure you didn’t activate the Net Balancer. In that case the default gateway is controlled by this module and not by the static configuration.

    Regards
    Fulvio

    #47504

    Ah, that would make sense. But, when I changed the Default Gateway, it looked like it automatically changed the Net Balancer Default Gateway setting. But I bet that was the problem. Maybe I had to go in and manually change it in the Net Balancer? Either way, thanks for all the help guys.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.