QOS Question (Updated)

Home Page Forums Network Management ZeroShell QOS Question (Updated)

This topic contains 3 replies, has 0 voices, and was last updated by  dingaling 11 years, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #40701

    dingaling
    Member

    Followed the QOS tutorial.
    But i am confused.

    It seemed that for global bandwidth, we are setting the ADSL downstream speed on 1 NIC, and the upstream bandwidth on the other NIC then assigning them classes for QOS to work.

    Unless i have understood wrong?

    So in my example i have a 512/128 adsl connection

    If i wanted to guarantee 80kbps on upload bandwidth and 256kbps on the downstream for VOIP for example, would i have to create 2 QOS classes for VOIP. one for the downstream NIC and one for the upstream NIC?

    Also just to clarify, do i leave the Bridge QOS disabled and with no classes assigned to it?

    THANX VERY MUCH IN ADVANCE!
    this software is really good!

    #45632

    imported_fulvio
    Participant

    @dingaling wrote:

    It seemed that for global bandwidth, we are setting the ADSL downstream speed on 1 NIC, and the upstream bandwidth on the other NIC then assigning them classes for QOS to work.

    Unless i have understood wrong?

    Ok, you have perfectly understood.

    @dingaling wrote:

    If i wanted to guarantee 80kbps on upload bandwidth and 256kbps on the downstream for VOIP for example, would i have to create 2 QOS classes for VOIP. one for the downstream NIC and one for the upstream NIC?

    You shoud not create different classes for the same service. You just have to create a class for any type of traffic and assign it to any interface. If you want asymmetric configuration you must set the local parameter of the class by clicking the [Modify Class] button in the interface manager.

    #45633

    dingaling
    Member

    thanx for clearing that up fulvio.

    But i still am having some issues.

    In the QOS statistics, some of my QOS classes are showing 0 bytes of activity.
    This would indicate that there is no QOS happening on traffic that isnt there?

    Even simple port 80 for web browsing doesnt appear to show any activity, it did count a few bytes on one of the interfaces.

    Also i notice the layer 7 filters for ventrillo and SIP are not registering any traffic in the QOS statistics. The voip phone i have tried to classify a few different ways (by IP, but MAC, by port, by l7 filter) and it doesnt seem to count any traffic, and cuts out when downloads are taking place.

    see attached image:

    My classifications look like this:
    1 * * MARK udp opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 udp spt:5060 dpt:5060 MARK set 0xb VOIP no
    2 * * MARK all opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto ventrilo MARK set 0xb VOIP no
    3 * * MARK tcp opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 tcp spt:80 MARK set 0x15 WEB no
    4 * * MARK all opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto flash MARK set 0x15 WEB no
    5 * * MARK all opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto bittorrent MARK set 0xf BULK no
    6 * * MARK all opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 ipp2p v0.8.2 –kazaa –gnu –edk –dc –bit LAYER7 l7proto bittorrent MARK set 0x12 BULK no
    7 * * MARK all opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto ftp MARK set 0x12 BULK no
    8 * * MARK all opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto smtp MARK set 0x12 BULK no
    9 * * MARK all opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto pop3 MARK set 0x12 BULK no
    10 * * MARK tcp opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 tcp spt:34085 MARK set 0x12 BULK no
    11 * * MARK udp opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 udp spt:34085 MARK set 0x12 BULK no

    Also i wonder if i should have NAT on/off in zeroshell if the adsl modem is doing NAT?

    Also i notice everday on the zero console i have a “Bad EIP value”
    something about Fixinf recursive fualty but reboot is needed”

    seems to come up everyday. Maybe this is why my QOS is not working?

    Kind Regards.

    #45634

    imported_fulvio
    Participant

    Your configuration looks corrects and I have no ideas why it does not work.
    The warning you obtain on the cosole I think it is related to the bios of your system. Could you try to change hardware?
    You can disable the NAT of the interface connected to the ADSL router only if your router has a static route which tell it that the LAN is routed by Zeroshell.

    Regards
    Fulvio

    #45635

    yuda
    Member

    you can use “commection tracking” to monitor packages
    Int filter key “udp”
    To find out voip packges
    modify qos

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.