qos on Vlan interfaces

Home Page Forums Network Management Networking qos on Vlan interfaces

This topic contains 2 replies, has 0 voices, and was last updated by  makaron24 11 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #40702

    makaron24
    Member

    Hello,
    At the beginning I would like say, big thanks to fulvio. Excellent soft.

    I have problem with QOS on vlan interfaces, of course I can create classes and filters but it’s impossible to attach classes to VLAN interfaces. I don’t see VLAN’s in QOS Interface Manager window.
    I solved problem by writting tc script. I created filters through www, and then i connected filter to classes and interfaces by script but it isn’t easy.

    tc qdisc del root dev ETH00.4
    tc qdisc add dev ETH00.4 root handle 1:0 htb
    tc class add dev ETH00.4 parent 1:0 classid 1:1 htb rate 20mbit ceil 20mbit
    tc class add dev ETH00.4 parent 1:1 classid 1:16 htb rate 1mbit ceil 1mbit
    tc qdisc add dev ETH00.4 parent 1:16 handle 16:0 sfq perturb 10
    tc filter add dev ETH00.4 parent 1: protocol ip prio 1 handle 0x10 fw classid 1:16

    Anyone know easiest way to do this ?? Mayby is a good idea to add vlan interfaces to qos managment?
    Best Regards
    Makaron

    #45636

    imported_fulvio
    Participant

    I don’t think that connecting the HTB qdisc directly to a VLAN 802.1q is a good ideas.
    This is because the vlan interfaces are logical interfaces and share their guaranteed bandwidth with other ones. My opinion is that htb qdis can be confused by bandwidth sharing.
    You could attach any class to the not tagged interface and use the classifier to assign the VLANS to the QoS classes.

    Regards
    Fulvio

    #45637

    makaron24
    Member

    Hello,
    I followed your advice and I checked all possibilities, but QOS on VLAN still doesn’t want work. Classifier works very good. I see changing counters on “pkts” “bytes” when I do iptables -v -L -t mangle, but traffic is shaped by default class on ETH00. I think this is because filter which get MARK from iptables is attached to wrong interface ETH00. Command tc -s filter show dev ETH00.4 (this is my vlan, ETH00 is native) doesn’t show any filters, with qdisc and with class is the same. I saw few scripts on LARC mailinglist and they using qdisc, class, and filters with VLAN interfaces. When I disable QOS on main interface ETH00, and add filter, class and qdisc from script to ETH00.4 everything works fine. As you wrote in FAQ VLAN interface is almost the same as regular so why we can’t add QOS ?
    Regards
    makaron

    #45638

    imported_fulvio
    Participant

    Ok, you are right.
    I will enable the web interface of Zeroshell to attach the qdisc directly on the VLAN interfaces, but I am not sure that I am able to do it in the next release.

    Regards and thank you for the advice
    Fulvio

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.