QOS nearly working – what am I missing?

Home Page Forums Network Management Firewall, Traffic Shaping and Net Balancer QOS nearly working – what am I missing?

This topic contains 7 replies, has 0 voices, and was last updated by  knitatoms 8 years, 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #42247

    knitatoms
    Member

    Thanks to Fulvio’s guide and some forum posts I have QOS nearly working.

    My setup is: ETH00 (LAN) and ETH02 (Wireless) bridged to BRIDGE00 so that LAN traffic works at full speed.

    Then I set QOS on ETH01 (connected to DSL modem) and ppp0. I can see QOS picking up traffic on ppp0 (traffic out) but not on ETH01 (traffic in). What am I doing wrong?

    #49781

    ppalias
    Member

    No need for QoS on ETH01.

    #49782

    knitatoms
    Member

    My understanding from Fulvio’s guide:

    http://www.zeroshell.net/eng/qos/

    was that to shape traffic both ways I need to activate QOS on two interfaces. This is especially important for me as we are on an asymmetric DSL line – so I need to allow more bandwidth down than up.

    I’ve set it up as shown because I’m hoping to leave the bridge between ETH00 (lan) and ETH02 (wireless) unrestricted so that the lan and wireless clients can communicate at full speed. But perhaps it’s not possible to do QOS between ppp0 and ETH01 because of how routing works (which I don’t really understand). Can I make it work as I’ve tried?

    #49783

    knitatoms
    Member

    OK – I put the classes onto ETH00 and ETH02 and it picks up the traffic as expected. This will do me for now – just won’t be able to copy files at full speed between wired and wireless LAN clients.

    #49784

    ppalias
    Member

    It is wrong to limit the inside BRIDGE00 interface. Also there is no point shaping incoming traffic, as you only delay the reception and cause retransmissions. Take my advise and leave QoS only on the outside interface ppp0. In case you want to limit the incoming traffic, you may reduce the outgoing rate of the ACKs.

    #49785

    knitatoms
    Member

    Ok – thanks for the advice. No idea how to limit download speed by limiting outgoing rate of ACKs – time to read an iptables and TCP book I think!

    #49786

    kingmaker
    Member

    thanks for sharing..

    #49787

    knitatoms
    Member

    Thanks to the info in this thread:

    http://www.zeroshell.net/eng/forum/viewtopic.php?t=1831

    I have got VOIP SIP packets being detected for QOS as shown in my screenshot above.

    Based on the advice from ppalias I am now only limiting outgoing traffic from my network.

    However I still have a problem with VOIP calls: when the network is busy we are getting regular drop outs in the voice. However this is only affecting us: The caller hears everything OK but we miss parts of what they are saying. This suggests to me that the QOS I have applied for outgoing packets is working well but because there is not QOS on incoming packets we are losing information.

    As our internet connection is ADSL and the upload speed is much slower than the download speed surely it should be possible for me to get this working better. The outgoing call quality is fine. Incoming is the problem but there is much more bandwidth that way.

    Is there definitely no point in trying to prioritise incoming SIP packets? I’ve done some reading around and I’m not able to come up with anything that will help me set up ‘limiting outgoing rates of ACKs’ as suggested above.

    Any help gratefully received.

    #49788

    ppalias
    Member

    If you want to prioritize incoming packets, you should ask it from your ISP, but I am not sure they would do that.
    You can try to prioritize outgoing ACKs in case this works for you. It is not hard, when you classify packets select TCP on protocol matching and then enable ACK.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.