Profiles partition out of space

Home Page Forums Network Management ZeroShell Profiles partition out of space

This topic contains 5 replies, has 0 voices, and was last updated by  pablokbs 7 years, 8 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #43138

    pablokbs
    Member

    Hi, I have zeroshell installed on a hard disk and it works great. i’ve just run out of space in my profile partition, my disk has 40GB of capacity but my profile partition only 800MB

    I have free space to make a new partition (about 37GB), using cfdisk I managed to create the new partition (/dev/hda4) and after that i tried to format it, and I got this error:

    root@zeroshell dev> mkfs.ext3 /dev/hda4
    mke2fs 1.41.1 (01-Sep-2008)
    mkfs.ext3: No such device or address while trying to determine filesystem size

    Using the web-ui I have the same problem, I see the partition but when I try to make the FS I get this error:

    Sep 29 09:38,18 ERROR: Partition /udev/hda4 not formatted.

    What can I do?

    NOTE: I CANT reboot or poweroff the server now, it is a production server, I want to make the partition FROM zeroshell

    Thanks!

    #51972

    try

    partprobe first … then mkfs.

    😉

    #51973

    pablokbs
    Member

    Thank you for your answer, but does not work:

    root@zeroshell root> partprobe /dev/hda4
    Error: Error opening /dev/hda4: No such device or address

    #51974

    please
    partprobe without option

    so

    # partprobe
    # fdisk -l
    # fdisk /dev/hda4

    root@vnpserver root> partprobe -s
    /dev/hdb: msdos partitions 1 2 3
    /dev/sda: msdos partitions 1 2 3
    /dev/sdb: msdos partitions 1
    Warning: Unable to open /dev/hda read-write (Read-only file system). /dev/hda has been opened read-only.
    root@vnpserver root>

    #51975

    pablokbs
    Member

    Perfect!

    Thanks

    #51976

    let me know, works ?

    #51977

    pablokbs
    Member

    Yes, it works, thanks 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.