problem activating the proxy service

Home Page Forums Network Management ZeroShell problem activating the proxy service

This topic contains 12 replies, has 0 voices, and was last updated by  thenach 10 years, 6 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #41047

    thenach
    Member

    Hi, I’m taking a problem activating the proxy service. I jump a error what say “Activating swap file ERROR”
    I parched the distribution with patch A500

    root@pcfiltro A500> ./install.sh
    Reading configuration …
    Extracting packages …
    Running scripts …
    Starting updater process for the release 1.0.beta9 …
    –> Checking for installed updates:
    [A500] Increase the stability of the proxy service
    [AA00] DansGuardian – True Web Content Filtering for All
    –> Replacing files …
    –> Running scripts …
    Activating swap file… [FAILED]
    Preparing DansGuardian…
    Checking HTTP Transparent Proxy and AntiVirus configuration…

    //



    root@pcfiltro init.d> ./proxy start
    Checking HTTP Transparent Proxy and AntiVirus configuration…
    –> Starting HAVP Proxy service…
    /root/kerbynet.cgi/scripts/proxy_start: line 69: 14678 Illegal instruction havp -c /tmp/havp.config >/dev/null 2>/dev/null
    –> Starting ClamAV AntiVirus AutoUpdate…
    root@pcfiltro init.d>

    Thanx in advance

    #46541

    imported_fulvio
    Participant

    Do not worry. The swap is correctly activated.

    Regards
    Fulvio

    #46542

    thenach
    Member

    thanx Fulvio for your response, but I can’t put the proxy status in up

    Nacho

    #46543

    imported_fulvio
    Participant

    Type the command

    havp

    and then:

    export LD_LIBRARY_PATH=/Database/opt/1.0/beta9/packages/lib
    /Database/opt/1.0/beta9/packages/sbin/havp

    in both the case you should obtain:

    Configuration is not edited!
    You must delete REMOVETHISLINE option.
    Review the configuration carefully. 🙂
    Exiting..

    Let me know the results

    Regards
    Fulvio

    #46544

    thenach
    Member

    Yess , I get that message.
    How can I keep doing that?

    #46545

    thenach
    Member

    I need the original and configurated hvap.conf file for this distribution.

    Who anybody help me?

    #46546

    imported_fulvio
    Participant

    Could you create a new database and try again?

    #46547

    thenach
    Member

    the machine is in production mode and configured with firewall rules, users and the captive portal.
    Create the database take me very long time. but if is necesary i do it

    what are your opinion?

    #46548

    imported_fulvio
    Participant

    Ok, to reset the proxy configuration you just need to type the following commands:

    rm -rf /var/register/system/havp/
    rm -rf /var/register/system/ClavAV

    and then restart the system.

    Regards
    Fulvio

    #46549

    kingjm
    Member

    I have followed the steps above

    rm -rf havp
    rm -rf ClamAV

    then reboot

    I still cannot activate the proxy.

    The proxy log shows

    00:00:38 === Starting HAVP Version: 0.89
    00:00:38 Running as user: havp, group: havp
    00:00:38 Use transparent proxy mode
    00:00:38 — Initializing ClamAV Library Scanner
    00:00:38 ClamAV: Using database directory: /var/register/system/ClamAV/db

    The antivirus log shows

    00:00:38 ClamAV: Using database directory: /var/register/system/ClamAV/db

    The update log is blank

    What can I do?

    #46550

    imported_fulvio
    Participant

    Check if there is at least 50MB of free space on the filesystem you are using to store the profile.

    Regards
    Fulvio

    #46551

    kingjm
    Member

    the total size is 193 MB. 117 MB is used. Leaving 76MB free. Could it be the ram I only have the minimum 96MB. Any other ideas?

    Thanks for helping. And this product is great!

    #46552

    kingjm
    Member

    I have created an new Hdd with 500MB and 128 MB Ram. The Proxy is now up. after activating the proxy the hdd is already at 40% full. I have not added in my own configuration at this time. Thankyou for your efforts and input.

    #46553

    imported_fulvio
    Participant

    If you use the proxy service you need at least 192MB of RAM. This is because the ClamAV libraries need to have the Virus signature decompressed into the RAM. To increase the performances you have to increase the size of the memory. In this case more havp processes are created.

    Regards
    Fulvio

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.