PPPoE over VLAN interface ?

Home Page Forums Network Management ZeroShell PPPoE over VLAN interface ?

This topic contains 7 replies, has 0 voices, and was last updated by  777maxism 4 years, 11 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #42402

    777maxism
    Member

    Hi Fulvio !!!
    Thank you for your product, a good solution to many problems …
    I would like to know you over here on this topic
    http://zeroshell.net/eng/forum/viewtopic.php?t=790&highlight=vlan+pppoe
    I have installed version 12 beta and version 11beta neither there nor there is not works ..
    The question can I do something wrong but when you create a PPPoE connections in column “Ethernet Modem connected to” does not select the VLAN, but only ETH00 or ETH01.
    How can I change it ???

    #50319

    atheling
    Member

    I am no expert on this, so take the following with some caution.

    PPPoE works directly on an Ethernet interface (or something that looks like it to the software like a VPN tun or tap interface).. See: http://en.wikipedia.org/wiki/Point-to-Point_Protocol_over_Ethernet

    The VLAN setups I have seen have all be based on the IP address subnets. So they are using the IP protocol on your Ethernet link.

    Because of this I believe that you are asking the impossible (a IP specific addressing setup on a protocol that does not use IP messages).

    #50320

    ppalias
    Member

    In Cisco router it is possible to open a PPPoE over a subinterface, so it not strange. I am not sure however if this behaviour is the appropriate or Cisco proprietary.

    #50321

    777maxism
    Member

    PPPoE works directly on an Ethernet interface.
    http://ru.wikipedia.org/wiki/PPPoE
    It says that the PPPoE supports the IEEE 802.3 network.
    http://ru.wikipedia.org/wiki/IEEE_802.3
    This table is standard 802.3ac describes support for VLAN.
    Based on this protocol PPPoE supports VLAN.

    #50322

    777maxism
    Member

    Sorry for my English, I use a translator … But I understand what they write.

    #50323

    ppalias
    Member

    Ok it seems to be a standard. So I suppose it is an ommittion of the ZS distribution to allow vlan interfaces to be used for PPPoE.
    Bug signaled!

    #50324

    777maxism
    Member

    I’m sorry but I do not understand that!!
    I have four ethernet cards
    ETH00 Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
    ETH01 VIA Technologies, Inc. VT6105/VT6106S [Rhine-III] (rev 8b)
    ETH02 Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
    ETH03 Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)

    VLANs I have registered on the interface ETH02 …
    When you create a PPPoE settings “Ethernet Modem connected to” does not select the VLAN, but only ETH00 – ETH03.
    When I created our test on one VLAN on each interface
    ETH00 vlan 2000
    ETH01 vlan 2001
    ETH02 vlan 2002
    ETH03 vlan 2003
    In the settings of PPPoE “Ethernet Modem connected to” interface appeared ETH00 vlan 2000, and all the other interfaces remain unchanged …

    #50325

    ppalias
    Member

    Definitely is some kind of bug, the web interface drop down list should include them all.

    #50326

    phoenixcomms
    Member

    ppalias refers to this as a bug in 2010.

    The bug manifests itself as an inability to select a VLAN when attempting to configure a PPPoE interface because only some of the VLANs are shown by the GUI. Selecting the basic interface ie ETHn works correctly.

    We have just upgraded to v3.0.0 and the bug is still there.

    Does anybody know if there is a fix / workaround to this problem.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.