pppd script failing [solved]

Home Page Forums Network Management Networking pppd script failing [solved]

This topic contains 0 replies, has 0 voices, and was last updated by  aristide 6 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #43369

    aristide
    Member

    Hi
    I am trying to set up a failover link over a 3g connection and have one problem and a question.

    First, the question:

    Is it possible to start the 3g connection only when needed (on demand) ?

    In my setup, it should only go up when the usual “wan”-connection (wlan) drops.

    Second, the problem:

    I can only fire up the ppp0 interface once. After it gets down, it cannot be started again.

    I get lots of message like this in the log (every 10 or so seconds):


    18:06:31 pppd 2.4.3 started by root, uid 0
    18:06:33 Connect script failed
    18:06:33 Exit.

    My provider (Orange Switzerland) may drop the connection after some time of inactivity, because I found this in the pppd-log:


    LCP terminated by peer

    But if I drop the connection myself, the problem is the same: no new connection is possible.

    Is there a way to have more infos in the pppd-log, in order to find the culprit (configuration or provider) ?

    Thx for any help and for ZeroShell[/quote]

    #52361

    aristide
    Member

    First, I have found out that my provider is dropping the connection after 30 minutes.

    Then, I think that pppd was failing to reconnect, because I had set the ppp0-interface to use a PIN-code for the SIM-card. After disabling the PIN-code on the SIM-card, pppd does reconnect automatically.

    It seems, that pppd only transmits the PIN-code to the SIM-card the first time it connects.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.