Possible Bug: Timezone setting not being saved

Home Page Forums Network Management ZeroShell Possible Bug: Timezone setting not being saved

This topic contains 4 replies, has 0 voices, and was last updated by  greyman 12 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #40533

    greyman
    Member

    During some rewiring in my network closet I noticed that after a reboot or power cycle that my zeroshell system was not maintaining its Timezone setting.

    The funny thing is that it defaults to CET and I am in CST.

    -Ron

    #45079

    imported_fulvio
    Participant

    I have just tested it now ant it works fine on my system.
    Did anyone else have the same problems with the time settings too?

    #45080

    greyman
    Member

    Just checked to see what was written to the filesystem on mine and at the moment it has the correct one. Where would I look to see what is written to the CF that would survive a shutdown or reboot when it comes back up.

    TIA

    #45081

    brian360
    Member

    I can confirm I am also having the same problem.

    ZeroShell is configured for “US/Pacific”, and the hw clock is set to UTC. When I reboot with these settings and bring up the Time Settings page, it still shows my selected time zone as US/Pacific, but the System Time display will report the time as being in “CET” (with an obviously incorrect time).

    Thanks,
    Brian

    #45082

    imported_fulvio
    Participant

    It is a bug that I introduced when I created the ISO images.
    In the livecd and compactflash the file /etc/localtime is stored in RAMDISK. Hence, any change is lost after the reboot.
    The fix will be available in the next release.

    Regards
    Fulvio

    #45083

    imported_fulvio
    Participant

    This bug is been fixed in the release 1.0.beta4

    Regards
    Fulvio

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.