Port Forwarding for IP Cameras a Real Challenge

Home Page Forums Network Management ZeroShell Port Forwarding for IP Cameras a Real Challenge

This topic contains 4 replies, has 0 voices, and was last updated by  kogonies 9 years, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #42160

    kogonies
    Member

    Hi Everyone,

    Let me start of by thanking Fulvio for a GREAT product!

    I’m new to ZeroShell and so far it’s been a breeze – setting up ZeroShell as a router/internet gateway with a 3G USB router. That was until now. I can’t get the port forwarding right!

    I am setting up a number of IP cameras as demos that must be accessible over the internet and would like to use ZeroShell to do the security and port forwarding of this little network. Everything is working – the IP cams have Internet access, the DDNS (through DynDNS) is set up and is accessible from the outside. But all I see is the ZeroShell login screen when I try to access a camera from outside.

    Am I missing something? Should I create a firewall rule, and how? Please help!

    Thanks in advance.

    DJ

    #49442

    Marcelo
    Member

    The problem here is that you access the cameras though ports 80/443, and ZS is alrready listening to those ports.

    Two steps that may help you:

    1 – Disable ZS admin interface from outsiders and make it accessible just from internal (LAN) clients (This is also a good security measure)–> this can be done under Setup / HTTPS Tab / “Allow access only from” and select just your LAN interface (be careful to select the LAN and not the WAN interface as this can prevent you from accessing the admin pages from the LAN if you pick the wrong one).

    2 – Since you’ve probably NATed your WAN interface, you can then use Setup / Network / Virtual Servers to map port 80 to one of the cameras OR select several different ports, one for each camera and translate each to port 80 of each camera’s LAN IP (you may also need to add firewall rules to allow such accesses in case you change the default FORWARD policy to DROP or REJECT). Note that if you choose ports different from 80 and 443 for each camera, step one is unecessary, but will still be a good security precaution…

    Goodluck

    #49443

    kogonies
    Member

    Thank you Marcelo for your advice. I did as you suggested, but still I can’t access the IP cameras from the Internet – I now only get a “Page cannot be displayed”.

    I’m pretty sure that the firewall is the culprit, but I’ve just spend the better part of 6 hours googling, adding and deleting firewall rules, changing the forwarding rules, testing… and still it does not work!

    Either I’m missing something or ZS can’t do port forwarding. Fact is, I’m about ready to forget about ZS and get another router to do the job.

    Any ideas?

    DJ

    #49444

    atheling
    Member

    Zeroshell can do port forwarding. I’m doing it for a number of ports on my public interfaces to different servers on my LAN. So it is something in your setup.

    The advice given by Marcelo was spot on. So go through his suggestion again and verify your settings with respect to NAT and virtual server setup.

    #49445

    atheling
    Member

    One more thought… And this would affect other routers too:

    How do these IP cameras send their video? Check the HTML they are generating and see if they are expecting another port to be opened for the video stream.

    #49446

    Marcelo
    Member

    Sorry if you already (probably) know this, kogonies, but just in case…

    If you did assign different ports for each camera as suggested, you will have to indicate to the browser the respective camera port you assigned when you want to access this specific camera:

    http://:

    So that this can be internally converted by Zeroshell to:

    http://:80

    Good luck!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.