Port Forwarding Error with Failover Link

Home Page Forums Network Management Firewall, Traffic Shaping and Net Balancer Port Forwarding Error with Failover Link

This topic contains 5 replies, has 0 voices, and was last updated by  sadnblueish 2 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #44516

    sadnblueish
    Member

    I have 2 links configured in failover mode. Primary link has Dynamic DNS. When configured in failover mode with 2 links (different priorities; Priority 10 for primary link and Priority 9 for backup link) zeroshell doesn’t do port forwarding. When the second link disabled (only primary link enabled in Net Balancer), zeroshell does the correct port forwarding.
    I am facing this issue from last 3-4 months. Before that port forwarding used to work perfectly.
    I am running latest ZS 3.5.0. The same error was present in previous release too. Kindly help.

    #54057

    sadnblueish
    Member

    No reply received so I decided to have few tests. Tested out by disabling many things which I had enabled and enabled few more which I wasn’t using. No luck!!!
    Then I booted the machine with .iso. It picked my saved profile from local disk and booted normally. Error is gone!!!
    I will check this scenario for few days more and then I will reinstall it on local disk.
    Though it has broken my subscription license but it’s working atleast.

    #54058

    sadnblueish
    Member

    OK. After few days of testing, it is still working. So I guess it’s some issue with the installed ZS which may have created some bug over time and multiple upgrades. I will go ahead and reinstall it.

    #54059

    dlitguy
    Member

    We have experienced the same issue with 3.3.2, 3.4.0, and 3.5.0 when booting from the iso.

    The issue with port forwarding for us was resolved when we either

      * disabled all but one gateway in the net balancer. (makes the net balancer useless)
      * removed the second IP from the LAN interface to leave us with only 1 IP per interface.
    #54060

    sadnblueish
    Member

    The problem is persistent on reboots. I mentioned this to Dev and he acknowledged the issue. He didn’t confirm the time to fix though.

    Enabling disabling multiple links and things like that somewhere fixes the problem temporarily but any change or reboot again brings the issue.
    Trying to live with this issue.

    For me, it’s not about booting from ISO or local disk. Same behaviour!

    #54061

    dlitguy
    Member

    The solution for us was to assign more nic adapters to the virtual machine, so we could stick to 1 IP per nic. This way we don’t have to disable and re-enable multiple IPs per nic, so the port forwarding keeps working even after reboots.

    Though this does increase the amount of rules required for things like the firewall.

    #54062

    sadnblueish
    Member

    Somehow that doesn’t apply to me as I have only 1 IP per NIC and I dont have ANY custom firewalling rules and Netbalancer rules. I use Zeroshell to balance between 2 internet streams; thats it.
    The problem persists for me.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.