Port Forwarding

Home Page Forums Network Management Networking Port Forwarding

This topic contains 2 replies, has 0 voices, and was last updated by  Galbrezu 10 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41318

    Galbrezu
    Member

    Alright, I’ve got a pretty basic router setup running ETH00 is my Gateway and ETH01 is connected to the internet.

    All I need to do is get some ports open for BitTorrent and a few other applications.

    Virtual Server doesn’t seem to be working and I can’t figure out the firewall options.

    Can anybody give me a hand or point me in the right direction?

    #47206

    vmv4
    Member

    Virtual server actually works. Try to disable firewall completely and give it a try.

    Regards, vmv4

    #47207

    Galbrezu
    Member

    Ok, got another question now, how do I turn off the firewall?

    #47208

    vmv4
    Member

    The simpliest way is to set “Policy” to “ACCEPT” under these chains: INPUT, FORWARD and OUTPUT. I believe you didn’t create custom chains. Also if there are any DROP rules within these chains, uncheck them under “Active” column.

    BitTorrent uses a range of ports, so it is not easy to add many rules via [Router] -> [Virtual Server]. Instead I’d suggest you to add single iptables command to startup sequence via menu [Setup] -> [Startup/Cron] -> [NAT and Virtual Servers]:

    iptables -t nat -A PREROUTING -p tcp -i ETH01 –destination-port 6881-6999 -j DNAT –to-destination=you.local.ip.address

    Regards,
    vmv4

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.